aboutsummaryrefslogtreecommitdiff
path: root/docs/examples/Makefile.am
diff options
context:
space:
mode:
authorYang Tse <yangsita@gmail.com>2009-11-05 15:04:03 +0000
committerYang Tse <yangsita@gmail.com>2009-11-05 15:04:03 +0000
commit55e68ba3338b02d9a52dfe6343054e61a944a895 (patch)
tree7c081754374ab5ee0cdbb1ad224c91adb152e63f /docs/examples/Makefile.am
parent3f56d1283020d3a6b8bc115080f2bb0d9a61fe27 (diff)
downloadgnurl-55e68ba3338b02d9a52dfe6343054e61a944a895.tar.gz
gnurl-55e68ba3338b02d9a52dfe6343054e61a944a895.tar.bz2
gnurl-55e68ba3338b02d9a52dfe6343054e61a944a895.zip
I removed leading 'curl' path on the 'curlbuild.h' include statement in
curl.h, adjusting auto-makefiles include path, to enhance portability to OS's without an orthogonal directory tree structure such as OS/400.
Diffstat (limited to 'docs/examples/Makefile.am')
-rw-r--r--docs/examples/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/docs/examples/Makefile.am b/docs/examples/Makefile.am
index 886e8ada6..2e4121d86 100644
--- a/docs/examples/Makefile.am
+++ b/docs/examples/Makefile.am
@@ -12,10 +12,12 @@ EXTRA_DIST = README Makefile.example Makefile.inc Makefile.m32 \
# being currently built and tested are searched before the library which
# might possibly already be installed in the system.
#
-# $(top_builddir)/include is for libcurl's generated curl/curlbuild.h file
+# $(top_builddir)/include/curl for generated curlbuild.h included from curl.h
+# $(top_builddir)/include for generated curlbuild.h included from lib/setup.h
# $(top_srcdir)/include is for libcurl's external include files
-INCLUDES = -I$(top_builddir)/include \
+INCLUDES = -I$(top_builddir)/include/curl \
+ -I$(top_builddir)/include \
-I$(top_srcdir)/include
LIBDIR = $(top_builddir)/lib