aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2001-05-22 18:16:24 +0000
committerDaniel Stenberg <daniel@haxx.se>2001-05-22 18:16:24 +0000
commit93c53424c813e1c177b6b35057adeac0f71b86ac (patch)
treedc456f62ee44dadf076468f96df3d0928ec7dc66 /configure.in
parent4a2812c5e84a9b6c9cc55e3c147441e3f61be9ac (diff)
downloadgnurl-93c53424c813e1c177b6b35057adeac0f71b86ac.tar.gz
gnurl-93c53424c813e1c177b6b35057adeac0f71b86ac.tar.bz2
gnurl-93c53424c813e1c177b6b35057adeac0f71b86ac.zip
cleanup commit for new autoconf+automake+libtool versions
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in25
1 files changed, 12 insertions, 13 deletions
diff --git a/configure.in b/configure.in
index 9a60a8aca..9bbc1f881 100644
--- a/configure.in
+++ b/configure.in
@@ -1,27 +1,30 @@
dnl $Id$
dnl Process this file with autoconf to produce a configure script.
-AC_INIT(lib/urldata.h)
+AC_INIT
+AC_CONFIG_SRCDIR([lib/urldata.h])
AM_CONFIG_HEADER(config.h src/config.h)
VERSION=`sed -ne 's/^#define LIBCURL_VERSION "\(.*\)"/\1/p' ${srcdir}/include/curl/curl.h`
AM_INIT_AUTOMAKE(curl,$VERSION)
-AM_PROG_LIBTOOL
dnl
dnl Detect the canonical host and target build environment
dnl
-AC_CANONICAL_HOST
-AC_CANONICAL_TARGET
-dnl Checks for programs.
-AC_PROG_CC
+dnl Get system canonical name
+AC_DEFINE_UNQUOTED(OS, "${host}")
dnl Check for AIX weirdos
AC_AIX
+dnl Checks for programs.
+AC_PROG_CC
+
dnl check for how to do large files
AC_SYS_LARGEFILE
+AM_PROG_LIBTOOL
+
dnl The install stuff has already been taken care of by the automake stuff
dnl AC_PROG_INSTALL
AC_PROG_MAKE_SET
@@ -751,11 +754,6 @@ if test "$socklen_t" != "yes"; then
AC_CHECK_TYPE(socklen_t, int)
fi
-
-dnl Get system canonical name
-AC_CANONICAL_HOST
-AC_DEFINE_UNQUOTED(OS, "${host}")
-
dnl Checks for library functions.
dnl AC_PROG_GCC_TRADITIONAL
AC_TYPE_SIGNAL
@@ -811,7 +809,7 @@ dnl AC_PATH_PROG( RANLIB, ranlib, /usr/bin/ranlib,
dnl $PATH:/usr/bin/:/usr/local/bin )
dnl AC_SUBST(RANLIB)
-AC_OUTPUT( Makefile \
+AC_CONFIG_FILES([Makefile \
docs/Makefile \
docs/examples/Makefile \
include/Makefile \
@@ -831,5 +829,6 @@ AC_OUTPUT( Makefile \
php/Makefile \
php/examples/Makefile \
curl-config
-)
+])
+AC_OUTPUT