aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJay Satiro <raysatiro@yahoo.com>2016-03-29 19:06:55 -0400
committerJay Satiro <raysatiro@yahoo.com>2016-03-29 19:06:55 -0400
commit79216287148c4ede29cd3a0b4c2dc961908c79d2 (patch)
tree2759adadb169efa7c922c3c1ee89045db3ecc7e6 /configure.ac
parent27c99a37ba55a78e3227c7058cf7533bb4aa7296 (diff)
downloadgnurl-79216287148c4ede29cd3a0b4c2dc961908c79d2.tar.gz
gnurl-79216287148c4ede29cd3a0b4c2dc961908c79d2.tar.bz2
gnurl-79216287148c4ede29cd3a0b4c2dc961908c79d2.zip
wolfssl: Use ECC supported curves extension
https://github.com/wolfSSL/wolfssl/issues/366
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b3ad5816f..6826b10a3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2206,11 +2206,13 @@ if test "$curl_ssl_msg" = "$init_ssl_msg"; then
dnl Recent WolfSSL versions build without SSLv3 by default
dnl WolfSSL needs configure --enable-opensslextra to have *get_peer*
AC_CHECK_FUNCS(wolfSSLv3_client_method \
+ wolfSSL_CTX_UseSupportedCurve \
wolfSSL_get_peer_certificate \
wolfSSL_UseALPN)
else
dnl Cyassl needs configure --enable-opensslextra to have *get_peer*
- AC_CHECK_FUNCS(CyaSSL_get_peer_certificate)
+ AC_CHECK_FUNCS(CyaSSL_CTX_UseSupportedCurve \
+ CyaSSL_get_peer_certificate)
fi
if test -n "$cyassllib"; then