aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2015-03-05 10:57:52 +0100
committerDaniel Stenberg <daniel@haxx.se>2015-03-05 10:57:52 +0100
commit709cf76f6bb7dbaca14e3e8df160ccfac04dcecb (patch)
treecffb2677079ffeb53bd6e5afbe623d6295a5eb7d /configure.ac
parent1a62b6e68c08c7e471ff22dd92932aba7e026817 (diff)
downloadgnurl-709cf76f6bb7dbaca14e3e8df160ccfac04dcecb.tar.gz
gnurl-709cf76f6bb7dbaca14e3e8df160ccfac04dcecb.tar.bz2
gnurl-709cf76f6bb7dbaca14e3e8df160ccfac04dcecb.zip
openssl: remove all uses of USE_SSLEAY
SSLeay was the name of the library that was subsequently turned into OpenSSL many moons ago (1999). curl does not work with the old SSLeay library since years. This is now reflected by only using USE_OPENSSL in code that depends on OpenSSL.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 7 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index df1d372f7..48a82b47f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1527,7 +1527,7 @@ if test "$curl_ssl_msg" = "$init_ssl_msg" && test X"$OPT_SSL" != Xno; then
else
- dnl Have the libraries--check for SSLeay/OpenSSL headers
+ dnl Have the libraries--check for OpenSSL headers
AC_CHECK_HEADERS(openssl/x509.h openssl/rsa.h openssl/crypto.h \
openssl/pem.h openssl/ssl.h openssl/err.h,
curl_ssl_msg="enabled (OpenSSL)"
@@ -1551,17 +1551,11 @@ if test "$curl_ssl_msg" = "$init_ssl_msg" && test X"$OPT_SSL" != Xno; then
fi
if test X"$OPENSSL_ENABLED" = X"1"; then
- AC_DEFINE(USE_SSLEAY, 1, [if SSL is enabled])
-
dnl is there a pkcs12.h header present?
AC_CHECK_HEADERS(openssl/pkcs12.h)
else
LIBS="$CLEANLIBS"
fi
- dnl USE_SSLEAY is the historical name for what configure calls
- dnl OPENSSL_ENABLED; the names should really be unified
- USE_SSLEAY="$OPENSSL_ENABLED"
- AC_SUBST(USE_SSLEAY)
if test X"$OPT_SSL" != Xoff &&
test "$OPENSSL_ENABLED" != "1"; then
@@ -1675,8 +1669,8 @@ dnl ---
if test "$OPENSSL_ENABLED" = "1"; then
AC_CHECK_LIB(crypto, SRP_Calc_client_key,
[
- AC_DEFINE(HAVE_SSLEAY_SRP, 1, [if you have the function SRP_Calc_client_key])
- AC_SUBST(HAVE_SSLEAY_SRP, [1])
+ AC_DEFINE(HAVE_OPENSSL_SRP, 1, [if you have the function SRP_Calc_client_key])
+ AC_SUBST(HAVE_OPENSSL_SRP, [1])
])
fi
@@ -3271,7 +3265,7 @@ AC_HELP_STRING([--disable-tls-srp],[Disable TLS-SRP authentication]),
want_tls_srp=yes
)
-if test "$want_tls_srp" = "yes" && ( test "x$HAVE_GNUTLS_SRP" = "x1" || test "x$HAVE_SSLEAY_SRP" = "x1") ; then
+if test "$want_tls_srp" = "yes" && ( test "x$HAVE_GNUTLS_SRP" = "x1" || test "x$HAVE_OPENSSL_SRP" = "x1") ; then
AC_DEFINE(USE_TLS_SRP, 1, [Use TLS-SRP authentication])
USE_TLS_SRP=1
curl_tls_srp_msg="enabled"
@@ -3385,7 +3379,7 @@ dnl For keeping supported features and protocols also in pkg-config file
dnl since it is more cross-compile friendly than curl-config
dnl
-if test "x$USE_SSLEAY" = "x1"; then
+if test "x$USE_OPENSSL" = "x1"; then
SUPPORT_FEATURES="$SUPPORT_FEATURES SSL"
elif test -n "$SSL_ENABLED"; then
SUPPORT_FEATURES="$SUPPORT_FEATURES SSL"
@@ -3424,7 +3418,7 @@ if test "x$CURL_DISABLE_CRYPTO_AUTH" != "x1" -a \
fi
if test "x$CURL_DISABLE_CRYPTO_AUTH" != "x1"; then
- if test "x$USE_SSLEAY" = "x1" -o "x$USE_WINDOWS_SSPI" = "x1" \
+ if test "x$USE_OPENSSL" = "x1" -o "x$USE_WINDOWS_SSPI" = "x1" \
-o "x$GNUTLS_ENABLED" = "x1" -o "x$NSS_ENABLED" = "x1" \
-o "x$DARWINSSL_ENABLED" = "x1"; then
SUPPORT_FEATURES="$SUPPORT_FEATURES NTLM"
@@ -3497,7 +3491,7 @@ if test "x$CURL_DISABLE_IMAP" != "x1"; then
fi
if test "x$CURL_DISABLE_SMB" != "x1" \
-a "x$CURL_DISABLE_CRYPTO_AUTH" != "x1" \
- -a \( "x$USE_SSLEAY" = "x1" -o "x$USE_WINDOWS_SSPI" = "x1" \
+ -a \( "x$USE_OPENSSL" = "x1" -o "x$USE_WINDOWS_SSPI" = "x1" \
-o "x$GNUTLS_ENABLED" = "x1" -o "x$NSS_ENABLED" = "x1" \
-o "x$DARWINSSL_ENABLED" = "x1" \); then
SUPPORT_PROTOCOLS="$SUPPORT_PROTOCOLS SMB"