aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMike Crowe <mac@mcrowe.com>2015-09-21 11:34:55 +0200
committerDaniel Stenberg <daniel@haxx.se>2015-09-22 17:30:33 +0200
commit6b56901b56e8d6247cdb86eeb042d6d4e2367003 (patch)
tree359370ff41205ba3f9cc9ad195156028b8fa7353 /configure.ac
parent7362008c1cbd6bb3079eae2f8217cd905749dd57 (diff)
downloadgnurl-6b56901b56e8d6247cdb86eeb042d6d4e2367003.tar.gz
gnurl-6b56901b56e8d6247cdb86eeb042d6d4e2367003.tar.bz2
gnurl-6b56901b56e8d6247cdb86eeb042d6d4e2367003.zip
gnutls: Support CURLOPT_KEYPASSWD
The gnutls vtls back-end was previously ignoring any password set via CURLOPT_KEYPASSWD. Presumably this was because gnutls_certificate_set_x509_key_file did not support encrypted keys. gnutls now has a gnutls_certificate_set_x509_key_file2 function that does support encrypted keys. Let's determine at compile time whether the available gnutls supports this new function. If it does then use it to pass the password. If it does not then emit a helpful diagnostic if a password is set. This is preferable to the previous behaviour of just failing to read the certificate without giving a reason in that case. Signed-off-by: Mike Crowe <mac@mcrowe.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 843a3badf..26d77eb87 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1836,6 +1836,7 @@ if test "$curl_ssl_msg" = "$init_ssl_msg"; then
AC_MSG_NOTICE([Added $gtlslib to LD_LIBRARY_PATH])
fi
fi
+ AC_CHECK_FUNCS(gnutls_certificate_set_x509_key_file2)
fi
fi