aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorIrfan Adilovic <i.adilovic@nfotex.com>2016-04-15 16:37:20 +0200
committerDaniel Stenberg <daniel@haxx.se>2016-04-21 23:08:28 +0200
commit14c8b45528467b488fd74af604ea7fe0a94c92bd (patch)
treeb57616cba107ee366ecec296b93fb253c4aa74d2 /configure.ac
parentcfe16c22d7891a1f65ea8cd4c5352504a2afbddc (diff)
downloadgnurl-14c8b45528467b488fd74af604ea7fe0a94c92bd.tar.gz
gnurl-14c8b45528467b488fd74af604ea7fe0a94c92bd.tar.bz2
gnurl-14c8b45528467b488fd74af604ea7fe0a94c92bd.zip
configure: ac_cv_ -> curl_cv_ for all cached vars
This was automated by: sed -b -i -f <(ack -A1 AC_CACHE_CHECK | \ ack -o 'ac_cv_.*?\b' | \ sort -u | xargs -n1 bash -c \ 'echo "s/$0/curl_cv_${0#ac_cv_}/g"') \ $(git ls-files) This only changed the prefix for 16 variables actually checked with AC_CACHE_CHECK.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 14 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index e7b0a9121..7891be025 100644
--- a/configure.ac
+++ b/configure.ac
@@ -339,7 +339,7 @@ dnl **********************************************************************
CURL_CHECK_HEADER_WINDOWS
CURL_CHECK_NATIVE_WINDOWS
-case X-"$ac_cv_native_windows" in
+case X-"$curl_cv_native_windows" in
X-yes)
CURL_CHECK_HEADER_WINSOCK
CURL_CHECK_HEADER_WINSOCK2
@@ -348,11 +348,11 @@ case X-"$ac_cv_native_windows" in
CURL_CHECK_HEADER_WINBER
;;
*)
- ac_cv_header_winsock_h="no"
- ac_cv_header_winsock2_h="no"
- ac_cv_header_ws2tcpip_h="no"
- ac_cv_header_winldap_h="no"
- ac_cv_header_winber_h="no"
+ curl_cv_header_winsock_h="no"
+ curl_cv_header_winsock2_h="no"
+ curl_cv_header_ws2tcpip_h="no"
+ curl_cv_header_winldap_h="no"
+ curl_cv_header_winber_h="no"
;;
esac
CURL_CHECK_WIN32_LARGEFILE
@@ -742,8 +742,8 @@ fi
if test "$HAVE_GETHOSTBYNAME" != "1"
then
dnl This is for winsock systems
- if test "$ac_cv_header_windows_h" = "yes"; then
- if test "$ac_cv_header_winsock_h" = "yes"; then
+ if test "$curl_cv_header_windows_h" = "yes"; then
+ if test "$curl_cv_header_winsock_h" = "yes"; then
case $host in
*-*-mingw32ce*)
winsock_LIB="-lwinsock"
@@ -753,7 +753,7 @@ then
;;
esac
fi
- if test "$ac_cv_header_winsock2_h" = "yes"; then
+ if test "$curl_cv_header_winsock2_h" = "yes"; then
winsock_LIB="-lws2_32"
fi
if test ! -z "$winsock_LIB"; then
@@ -988,7 +988,7 @@ if test x$CURL_DISABLE_LDAP != x1 ; then
CURL_CHECK_HEADER_LDAP_SSL
if test -z "$LDAPLIBNAME" ; then
- if test "$ac_cv_native_windows" = "yes"; then
+ if test "$curl_cv_native_windows" = "yes"; then
dnl Windows uses a single and unique LDAP library name
LDAPLIBNAME="wldap32"
LBERLIBNAME="no"
@@ -1338,7 +1338,7 @@ AC_HELP_STRING([--without-winssl], [disable Windows native SSL/TLS]),
AC_MSG_CHECKING([whether to enable Windows native SSL/TLS (Windows native builds only)])
if test "$curl_ssl_msg" = "$init_ssl_msg"; then
if test "x$OPT_WINSSL" != "xno" &&
- test "x$ac_cv_native_windows" = "xyes"; then
+ test "x$curl_cv_native_windows" = "xyes"; then
AC_MSG_RESULT(yes)
AC_DEFINE(USE_SCHANNEL, 1, [to enable Windows native SSL/TLS support])
AC_SUBST(USE_SCHANNEL, [1])
@@ -3162,7 +3162,7 @@ AC_CHECK_SIZEOF(time_t)
AC_CHECK_SIZEOF(off_t)
soname_bump=no
-if test x"$ac_cv_native_windows" != "xyes" &&
+if test x"$curl_cv_native_windows" != "xyes" &&
test $ac_cv_sizeof_off_t -ne $curl_sizeof_curl_off_t; then
AC_MSG_WARN([This libcurl built is probably not ABI compatible with previous])
AC_MSG_WARN([builds! You MUST read lib/README.curl_off_t to figure it out.])
@@ -3397,7 +3397,7 @@ AM_CONDITIONAL(USE_MANUAL, test x"$USE_MANUAL" = x1)
CURL_CHECK_LIB_ARES
AM_CONDITIONAL(USE_EMBEDDED_ARES, test x$embedded_ares = xyes)
-if test "x$ac_cv_native_windows" != "xyes" &&
+if test "x$curl_cv_native_windows" != "xyes" &&
test "x$enable_shared" = "xyes"; then
build_libhostname=yes
else
@@ -3467,7 +3467,7 @@ AC_HELP_STRING([--enable-sspi],[Enable SSPI])
AC_HELP_STRING([--disable-sspi],[Disable SSPI]),
[ case "$enableval" in
yes)
- if test "$ac_cv_native_windows" = "yes"; then
+ if test "$curl_cv_native_windows" = "yes"; then
AC_MSG_RESULT(yes)
AC_DEFINE(USE_WINDOWS_SSPI, 1, [to enable SSPI support])
AC_SUBST(USE_WINDOWS_SSPI, [1])