summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2015-01-22 23:04:10 +0100
committerDaniel Stenberg <daniel@haxx.se>2015-01-22 23:04:10 +0100
commite888e30476c9bbb0f6fd0a79737197156dc0a99c (patch)
tree314679ff070b321ad4f86569f8e893049dd83c10 /configure.ac
parent3d5648f9ee08cdbd6297978c8e67d02b90ba0151 (diff)
downloadgnurl-e888e30476c9bbb0f6fd0a79737197156dc0a99c.tar.gz
gnurl-e888e30476c9bbb0f6fd0a79737197156dc0a99c.tar.bz2
gnurl-e888e30476c9bbb0f6fd0a79737197156dc0a99c.zip
BoringSSL: fix build for non-configure builds
HAVE_BORINGSSL gets defined now by configure and should be defined by other build systems in case a BoringSSL build is desired.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 61968b942..7193e2790 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1617,6 +1617,8 @@ if test "$curl_ssl_msg" = "$init_ssl_msg" && test X"$OPT_SSL" != Xno; then
AC_MSG_CHECKING([for BoringSSL])
if test "x$ac_cv_func_DES_set_odd_parity" != "xyes"; then
curl_ssl_msg="enabled (BoringSSL)"
+ AC_DEFINE_UNQUOTED(HAVE_BORINGSSL, 1,
+ [Define to 1 if using BoringSSL.])
AC_MSG_RESULT([yes])
else
AC_MSG_RESULT([no])