summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2014-11-09 15:42:12 +0100
committerDaniel Stenberg <daniel@haxx.se>2014-11-09 15:43:27 +0100
commit9dbbba997608f7c3c5de1c627c77c8cd2aa85b73 (patch)
tree80e7f46f1a83acbf4d1427c573ffd099af11b564 /configure.ac
parent18e1a3022deebfa91ef022f09de3396d595f50b2 (diff)
downloadgnurl-9dbbba997608f7c3c5de1c627c77c8cd2aa85b73.tar.gz
gnurl-9dbbba997608f7c3c5de1c627c77c8cd2aa85b73.tar.bz2
gnurl-9dbbba997608f7c3c5de1c627c77c8cd2aa85b73.zip
libssh2: detect features based on version, not configure checks
... so that non-configure builds get the correct functions too based on the libssh2 version used.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 0 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index d37fd92fb..0ad8fc964 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2332,12 +2332,6 @@ if test X"$OPT_LIBSSH2" != Xno; then
dnl linker doesn't search through, we need to add it to LD_LIBRARY_PATH
dnl to prevent further configure tests to fail due to this
- dnl libssh2_version is a post 1.0 addition
- dnl libssh2_init and libssh2_exit were added in 1.2.5
- dnl libssh2_scp_send64 was added in 1.2.6
- dnl libssh2_session_handshake was added in 1.2.8
- AC_CHECK_FUNCS( libssh2_version libssh2_init libssh2_exit \
- libssh2_scp_send64 libssh2_session_handshake)
if test "x$cross_compiling" != "xyes"; then
LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$DIR_SSH2"
export LD_LIBRARY_PATH