summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDagobert Michelsen <dam@opencsw.org>2015-03-30 14:18:21 +0200
committerDaniel Stenberg <daniel@haxx.se>2015-03-30 14:19:23 +0200
commit5b668606527613179d0349f21b4ab0df2971e3d2 (patch)
treed1ec905837e51b21119ceadb06c3dc48bd15041f /configure.ac
parent787c2ae91b1f172ce9fdd2b6613c6217c00a85b3 (diff)
downloadgnurl-5b668606527613179d0349f21b4ab0df2971e3d2.tar.gz
gnurl-5b668606527613179d0349f21b4ab0df2971e3d2.tar.bz2
gnurl-5b668606527613179d0349f21b4ab0df2971e3d2.zip
configure: Use KRB5CONFIG for krb5-config
Allows the user to easier override its path. Bug: http://curl.haxx.se/bug/view.cgi?id=1486
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 1ae6b6e4a..098629801 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1184,6 +1184,8 @@ AC_ARG_WITH(gssapi,
fi
])
+: ${KRB5CONFIG:="$GSSAPI_ROOT/bin/krb5-config"}
+
save_CPPFLAGS="$CPPFLAGS"
AC_MSG_CHECKING([if GSS-API support is requested])
if test x"$want_gss" = xyes; then
@@ -1194,6 +1196,8 @@ if test x"$want_gss" = xyes; then
GSSAPI_INCS=`$GSSAPI_ROOT/bin/$host_alias-krb5-config --cflags gssapi`
elif test -f "$GSSAPI_ROOT/bin/krb5-config"; then
GSSAPI_INCS=`$GSSAPI_ROOT/bin/krb5-config --cflags gssapi`
+ elif test -f "$KRB5CONFIG"; then
+ GSSAPI_INCS=`$KRB5CONFIG --cflags gssapi`
elif test "$GSSAPI_ROOT" != "yes"; then
GSSAPI_INCS="-I$GSSAPI_ROOT/include"
fi
@@ -1283,10 +1287,10 @@ if test x"$want_gss" = xyes; then
dnl into LIBS
gss_libs=`$GSSAPI_ROOT/bin/$host_alias-krb5-config --libs gssapi`
LIBS="$gss_libs $LIBS"
- elif test -f "$GSSAPI_ROOT/bin/krb5-config"; then
+ elif test -f "$KRB5CONFIG"; then
dnl krb5-config doesn't have --libs-only-L or similar, put everything
dnl into LIBS
- gss_libs=`$GSSAPI_ROOT/bin/krb5-config --libs gssapi`
+ gss_libs=`$KRB5CONFIG --libs gssapi`
LIBS="$gss_libs $LIBS"
else
case $host in