summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Howarth <paul@city-fan.org>2015-01-09 09:49:20 +0000
committerDaniel Stenberg <daniel@haxx.se>2015-03-26 13:23:37 +0100
commit559e2cc921c58998f1f58ef47ba34901709fd55b (patch)
treecf35c0b6fb0cad9bc04c81993b1a2df72644cb7f /configure.ac
parent318ad8d767a982b33c828d08bf9eddb5b32d21df (diff)
downloadgnurl-559e2cc921c58998f1f58ef47ba34901709fd55b.tar.gz
gnurl-559e2cc921c58998f1f58ef47ba34901709fd55b.tar.bz2
gnurl-559e2cc921c58998f1f58ef47ba34901709fd55b.zip
build: link curl to openssl libraries when openssl support is enabled
This fixes a build failure where openssl and libmetalink are used together and the system linker does not do implicit linking (e.g. Fedora 13 and later releases). The MD5 functions required for metalink support must be pulled in from the openssl crypto library. This is similar to commit c6e7cbb94e669b85d3eb8e015ec51d0072112133, which fixes the same sort of problem for NSS builds.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5af07b90e..1ae6b6e4a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1451,6 +1451,7 @@ if test "$curl_ssl_msg" = "$init_ssl_msg" && test X"$OPT_SSL" != Xno; then
SSL_CPPFLAGS=`CURL_EXPORT_PCDIR([$OPENSSL_PCDIR]) dnl
$PKGCONFIG --cflags-only-I openssl 2>/dev/null`
+ AC_SUBST(SSL_LIBS)
AC_MSG_NOTICE([pkg-config: SSL_LIBS: "$SSL_LIBS"])
AC_MSG_NOTICE([pkg-config: SSL_LDFLAGS: "$SSL_LDFLAGS"])
AC_MSG_NOTICE([pkg-config: SSL_CPPFLAGS: "$SSL_CPPFLAGS"])