summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2015-01-22 22:51:17 +0100
committerDaniel Stenberg <daniel@haxx.se>2015-01-22 22:52:53 +0100
commit3d5648f9ee08cdbd6297978c8e67d02b90ba0151 (patch)
tree0308394287e09e964e613e912566d68e8eb3a44a /configure.ac
parent12e45b846268cf87660c8a2f8952817c33690db2 (diff)
downloadgnurl-3d5648f9ee08cdbd6297978c8e67d02b90ba0151.tar.gz
gnurl-3d5648f9ee08cdbd6297978c8e67d02b90ba0151.tar.bz2
gnurl-3d5648f9ee08cdbd6297978c8e67d02b90ba0151.zip
configure: fix BoringSSL detection and detect libresssl
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 16 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2cfe7dd75..61968b942 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1615,12 +1615,27 @@ if test "$curl_ssl_msg" = "$init_ssl_msg" && test X"$OPT_SSL" != Xno; then
AC_MSG_RESULT([no])
])
AC_MSG_CHECKING([for BoringSSL])
- if test "x$ac_cv_func_des_set_odd_parity" != "xyes"; then
+ if test "x$ac_cv_func_DES_set_odd_parity" != "xyes"; then
curl_ssl_msg="enabled (BoringSSL)"
AC_MSG_RESULT([yes])
else
AC_MSG_RESULT([no])
fi
+ AC_MSG_CHECKING([for libressl])
+ AC_COMPILE_IFELSE([
+ AC_LANG_PROGRAM([[
+#include <openssl/opensslv.h>
+ ]],[[
+ int dummy = LIBRESSL_VERSION_NUMBER;
+ ]])
+ ],[
+ AC_MSG_RESULT([yes])
+ AC_DEFINE_UNQUOTED(HAVE_LIBRESSL, 1,
+ [Define to 1 if using libressl.])
+ curl_ssl_msg="enabled (libressl)"
+ ],[
+ AC_MSG_RESULT([no])
+ ])
fi
if test "$OPENSSL_ENABLED" = "1"; then