summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBill Nagel <wnagel@tycoint.com>2014-11-29 12:59:29 -0500
committerSteve Holme <steve_holme@hotmail.com>2014-11-29 18:10:38 +0000
commit3529903afb1db05892e03f7c3c836859f3b18a34 (patch)
treee4a371f4a6d763070fba9c3fd0d0fea4603473a2 /configure.ac
parent86981ac9f5d8f826b0724bd49ce5c04b6c8e5c65 (diff)
downloadgnurl-3529903afb1db05892e03f7c3c836859f3b18a34.tar.gz
gnurl-3529903afb1db05892e03f7c3c836859f3b18a34.tar.bz2
gnurl-3529903afb1db05892e03f7c3c836859f3b18a34.zip
smb: Added configuration options for SMB
Added --enable-smb and --disable-smb configuration options for the upcoming SMB/CIFS protocol support.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 22 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1adb2a5c4..ce27853f5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -574,6 +574,22 @@ AC_HELP_STRING([--disable-imap],[Disable IMAP support]),
)
+AC_MSG_CHECKING([whether to support smb])
+AC_ARG_ENABLE(smb,
+AC_HELP_STRING([--enable-smb],[Enable SMB/CIFS support])
+AC_HELP_STRING([--disable-smb],[Disable SMB/CIFS support]),
+[ case "$enableval" in
+ no)
+ AC_MSG_RESULT(no)
+ AC_DEFINE(CURL_DISABLE_SMB, 1, [to disable SMB/CIFS])
+ AC_SUBST(CURL_DISABLE_SMB, [1])
+ ;;
+ *) AC_MSG_RESULT(yes)
+ ;;
+ esac ],
+ AC_MSG_RESULT(yes)
+)
+
AC_MSG_CHECKING([whether to support smtp])
AC_ARG_ENABLE(smtp,
AC_HELP_STRING([--enable-smtp],[Enable SMTP support])
@@ -3439,6 +3455,12 @@ if test "x$CURL_DISABLE_IMAP" != "x1"; then
SUPPORT_PROTOCOLS="$SUPPORT_PROTOCOLS IMAPS"
fi
fi
+if test "x$CURL_DISABLE_SMB" != "x1"; then
+ SUPPORT_PROTOCOLS="$SUPPORT_PROTOCOLS SMB"
+ if test "x$SSL_ENABLED" = "x1"; then
+ SUPPORT_PROTOCOLS="$SUPPORT_PROTOCOLS SMBS"
+ fi
+fi
if test "x$CURL_DISABLE_SMTP" != "x1"; then
SUPPORT_PROTOCOLS="$SUPPORT_PROTOCOLS SMTP"
if test "x$SSL_ENABLED" = "x1"; then