summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon Legner <Simon.Legner@gmail.com>2019-02-10 22:06:42 +0100
committerDaniel Stenberg <daniel@haxx.se>2019-03-02 11:31:18 +0100
commite075b2149b5d287b30718b31bee5ba80aba3da94 (patch)
treed61cc8aca0eed5aaaa3aae88aa32e9f8ca85142b /configure.ac
parent15cbf8dec68cdd9e5c7fd6807d8f75b1f5b27501 (diff)
downloadgnurl-e075b2149b5d287b30718b31bee5ba80aba3da94.tar.gz
gnurl-e075b2149b5d287b30718b31bee5ba80aba3da94.tar.bz2
gnurl-e075b2149b5d287b30718b31bee5ba80aba3da94.zip
scripts/completion.pl: also generate fish completion file
This is the renamed script formerly known as zsh.pl Closes #3545
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac25
1 files changed, 25 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ab5275a8f..bb1a68508 100755
--- a/configure.ac
+++ b/configure.ac
@@ -3413,6 +3413,31 @@ case "$OPT_ZSH_FPATH" in
esac
dnl **********************************************************************
+dnl Check for fish completion path
+dnl **********************************************************************
+
+OPT_FISH_FPATH=default
+AC_ARG_WITH(fish-functions-dir,
+AC_HELP_STRING([--with-fish-functions-dir=PATH],[Install fish completions to PATH])
+AC_HELP_STRING([--without-fish-functions-dir],[Do not install fish completions]),
+ [OPT_FISH_FPATH=$withval])
+case "$OPT_FISH_FPATH" in
+ no)
+ dnl --without-fish-functions-dir option used
+ ;;
+ default|yes)
+ dnl --with-fish-functions-dir option used without path
+ FISH_FUNCTIONS_DIR="$datarootdir/fish/completions"
+ AC_SUBST(FISH_FUNCTIONS_DIR)
+ ;;
+ *)
+ dnl --with-fish-functions-dir option used with path
+ FISH_FUNCTIONS_DIR="$withval"
+ AC_SUBST(FISH_FUNCTIONS_DIR)
+ ;;
+esac
+
+dnl **********************************************************************
dnl Back to "normal" configuring
dnl **********************************************************************