summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNils Gillmann <ng0@n0.is>2018-11-10 16:48:24 +0000
committerNils Gillmann <ng0@n0.is>2018-11-10 16:48:24 +0000
commit92533ade41f9b4860248c92bbcb3ee5d2bac0d66 (patch)
tree56919dee5ad5455a75045e7e0ead8eabc7bd5886 /configure.ac
parent544c3c6aed15d4198ccc1d38cfaee6329faadaf0 (diff)
parent196677150f711a96c38ed123e621f1d4e995b2e5 (diff)
downloadgnurl-92533ade41f9b4860248c92bbcb3ee5d2bac0d66.tar.gz
gnurl-92533ade41f9b4860248c92bbcb3ee5d2bac0d66.tar.bz2
gnurl-92533ade41f9b4860248c92bbcb3ee5d2bac0d66.zip
Merge tag 'curl-7_62_0'
7.62.0 Signed-off-by: Nils Gillmann <ng0@n0.is>
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac59
1 files changed, 29 insertions, 30 deletions
diff --git a/configure.ac b/configure.ac
index 113db4a43..0c0e46a9e 100755
--- a/configure.ac
+++ b/configure.ac
@@ -158,7 +158,7 @@ AC_SUBST(PKGADD_VENDOR)
dnl
dnl initialize all the info variables
- curl_ssl_msg="no (--with-{ssl,gnutls,nss,polarssl,mbedtls,cyassl,axtls,winssl,darwinssl} )"
+ curl_ssl_msg="no (--with-{ssl,gnutls,nss,polarssl,mbedtls,cyassl,axtls,winssl,darwinssl,mesalink} )"
curl_ssh_msg="no (--with-libssh2)"
curl_zlib_msg="no (--with-zlib)"
curl_brotli_msg="no (--with-brotli)"
@@ -1527,6 +1527,20 @@ if test "$OPENSSL_ENABLED" = "1"; then
])
fi
+dnl ---
+dnl Whether the OpenSSL configuration will be loaded automatically
+dnl ---
+if test X"$OPENSSL_ENABLED" = X"1"; then
+AC_ARG_ENABLE(openssl-auto-load-config,
+AC_HELP_STRING([--enable-openssl-auto-load-config],[Enable automatic loading of OpenSSL configuration])
+AC_HELP_STRING([--disable-openssl-auto-load-config],[Disable automatic loading of OpenSSL configuration]),
+[ if test X"$enableval" = X"no"; then
+ AC_MSG_NOTICE([automatic loading of OpenSSL configuration disabled])
+ AC_DEFINE(CURL_DISABLE_OPENSSL_AUTO_LOAD_CONFIG, 1, [if the OpenSSL configuration won't be loaded automatically])
+ fi
+])
+fi
+
dnl ----------------------------------------------------
dnl check for GnuTLS
dnl ----------------------------------------------------
@@ -1687,39 +1701,18 @@ if test "$GNUTLS_ENABLED" = "1"; then
])
fi
-dnl ----------------------------------------------------
-dnl check for PolarSSL
-dnl ----------------------------------------------------
-
-dnl Default to compiler & linker defaults for PolarSSL files & libraries.
OPT_POLARSSL=no
-
-dnl ----------------------------------------------------
-dnl check for mbedTLS
-dnl ----------------------------------------------------
-
OPT_MBEDTLS=no
-
-dnl ----------------------------------------------------
-dnl check for CyaSSL
-dnl ----------------------------------------------------
-
-dnl Default to compiler & linker defaults for CyaSSL files & libraries.
OPT_CYASSL=no
-
-dnl ----------------------------------------------------
dnl NSS. Only check if GnuTLS and OpenSSL are not enabled
-dnl ----------------------------------------------------
-
-dnl Default to compiler & linker defaults for NSS files & libraries.
OPT_NSS=no
-
OPT_AXTLS=off
+OPT_MESALINK=no
-case "x$OPENSSL_ENABLED$GNUTLS_ENABLED$NSS_ENABLED$POLARSSL_ENABLED$MBEDTLS_ENABLED$AXTLS_ENABLED$CYASSL_ENABLED$WINSSL_ENABLED$DARWINSSL_ENABLED" in
+case "x$OPENSSL_ENABLED$GNUTLS_ENABLED$NSS_ENABLED$POLARSSL_ENABLED$MBEDTLS_ENABLED$AXTLS_ENABLED$CYASSL_ENABLED$WINSSL_ENABLED$DARWINSSL_ENABLED$MESALINK_ENABLED" in
x)
AC_MSG_WARN([SSL disabled, you will not be able to use HTTPS, FTPS, NTLM and more.])
- AC_MSG_WARN([Use --with-ssl, --with-gnutls, --with-polarssl, --with-cyassl, --with-nss, --with-axtls, --with-winssl, or --with-darwinssl to address this.])
+ AC_MSG_WARN([Use --with-ssl, --with-gnutls, --with-polarssl, --with-cyassl, --with-nss, --with-axtls, --with-winssl, --with-darwinssl, or --with-mesalink to address this.])
;;
x1)
# one SSL backend is enabled
@@ -2110,7 +2103,7 @@ fi
dnl Let's hope this split URL remains working:
-dnl http://publibn.boulder.ibm.com/doc_link/en_US/a_doc_lib/aixprggd/ \
+dnl https://www15.software.ibm.com/doc_link/en_US/a_doc_lib/aixprggd/ \
dnl genprogc/thread_quick_ref.htm
@@ -2408,8 +2401,6 @@ CURL_RUN_IFELSE(
AC_MSG_RESULT([no])
])
-CURL_CONFIGURE_CURL_SOCKLEN_T
-
CURL_CONFIGURE_PULL_SYS_POLL
TYPE_IN_ADDR_T
@@ -2655,6 +2646,16 @@ if test "$want_pthreads" != "no"; then
dnl first check for function without lib
AC_CHECK_FUNC(pthread_create, [USE_THREADS_POSIX=1] )
+ dnl on HPUX, life is more complicated...
+ case $host in
+ *-hp-hpux*)
+ dnl it doesn't actually work without -lpthread
+ USE_THREADS_POSIX=""
+ ;;
+ *)
+ ;;
+ esac
+
dnl if it wasn't found without lib, search for it in pthread lib
if test "$USE_THREADS_POSIX" != "1"
then
@@ -3096,8 +3097,6 @@ AC_CONFIG_FILES([Makefile \
packages/Linux/RPM/curl.spec \
packages/Linux/RPM/curl-ssl.spec \
packages/Solaris/Makefile \
- packages/EPM/curl.list \
- packages/EPM/Makefile \
packages/vms/Makefile \
packages/AIX/Makefile \
packages/AIX/RPM/Makefile \