summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPhilipp Waehnert <philipp.waehnert@mgm-tp.com>2018-07-25 11:00:15 +0200
committerDaniel Stenberg <daniel@haxx.se>2018-09-07 09:38:33 +0200
commit6684653b682bae0be75ea62bb473b126923952f1 (patch)
tree3e5749139cd2cdaba658fbd530473c51beffe197 /configure.ac
parentc515294cec6ee9b72d68e6f13dc1972bcf3fed30 (diff)
downloadgnurl-6684653b682bae0be75ea62bb473b126923952f1.tar.gz
gnurl-6684653b682bae0be75ea62bb473b126923952f1.tar.bz2
gnurl-6684653b682bae0be75ea62bb473b126923952f1.zip
configure: add option to disable automatic OpenSSL config loading
Sometimes it may be considered a security risk to load an external OpenSSL configuration automatically inside curl_global_init(). The configuration option --disable-ssl-auto-load-config disables this automatism. The Windows build scripts winbuild/Makefile.vs provide a corresponding option ENABLE_SSL_AUTO_LOAD_CONFIG accepting a boolean value. Setting neither of these options corresponds to the previous behavior loading the external OpenSSL configuration automatically. Fixes #2724 Closes #2791
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ff8f5df9b..1e068cb37 100755
--- a/configure.ac
+++ b/configure.ac
@@ -1876,6 +1876,20 @@ if test "$OPENSSL_ENABLED" = "1"; then
])
fi
+dnl ---
+dnl Whether the OpenSSL configuration will be loaded automatically
+dnl ---
+if test X"$OPENSSL_ENABLED" = X"1"; then
+AC_ARG_ENABLE(openssl-auto-load-config,
+AC_HELP_STRING([--enable-openssl-auto-load-config],[Enable automatic loading of OpenSSL configuration])
+AC_HELP_STRING([--disable-openssl-auto-load-config],[Disable automatic loading of OpenSSL configuration]),
+[ if test X"$enableval" = X"no"; then
+ AC_MSG_NOTICE([automatic loading of OpenSSL configuration disabled])
+ AC_DEFINE(CURL_DISABLE_OPENSSL_AUTO_LOAD_CONFIG, 1, [if the OpenSSL configuration won't be loaded automatically])
+ fi
+])
+fi
+
dnl ----------------------------------------------------
dnl check for GnuTLS
dnl ----------------------------------------------------