summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2018-06-08 16:36:47 +0200
committerDaniel Stenberg <daniel@haxx.se>2018-06-11 10:20:18 +0200
commit38203f1585da53e07e54e37c7d5da4d72f509a2e (patch)
treece206e4bb0b26c4155a864be32f82397a1d2eab5 /configure.ac
parent100318c7fd934fa260f790d03808860c9b6cec68 (diff)
downloadgnurl-38203f1585da53e07e54e37c7d5da4d72f509a2e.tar.gz
gnurl-38203f1585da53e07e54e37c7d5da4d72f509a2e.tar.bz2
gnurl-38203f1585da53e07e54e37c7d5da4d72f509a2e.zip
openssl: assume engine support in 1.0.1 or later
Previously it was checked for in configure/cmake, but that would then leave other build systems built without engine support. While engine support probably existed prior to 1.0.1, I decided to play safe. If someone experience a problem with this, we can widen the version check. Fixes #2641 Closes #2644
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac8
1 files changed, 0 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index fa5dc84f5..a9fd3d103 100755
--- a/configure.ac
+++ b/configure.ac
@@ -1756,14 +1756,6 @@ if test -z "$ssl_backends" -o "x$OPT_SSL" != xno &&
fi
if test X"$OPENSSL_ENABLED" = X"1"; then
- dnl If the ENGINE library seems to be around, check for the OpenSSL engine
- dnl stuff, it is kind of "separated" from the main SSL check
- AC_CHECK_FUNC(ENGINE_init,
- [
- AC_CHECK_HEADERS(openssl/engine.h)
- AC_CHECK_FUNCS( ENGINE_load_builtin_engines )
- ])
-
dnl These can only exist if OpenSSL exists
dnl Older versions of Cyassl (some time before 2.9.4) don't have
dnl SSL_get_shutdown (but this check won't actually detect it there