summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorng0 <ng0@n0.is>2019-01-17 08:27:50 +0000
committerng0 <ng0@n0.is>2019-01-17 08:27:50 +0000
commit1e542d031dc565ae2d808b98413613dda77bf646 (patch)
treec172982496f5bd770f9df15ee801ea59486a7629 /configure.ac
parentdb1a5b9e79953bdabb8f97293513fe2b589a38c8 (diff)
downloadgnurl-1e542d031dc565ae2d808b98413613dda77bf646.tar.gz
gnurl-1e542d031dc565ae2d808b98413613dda77bf646.tar.bz2
gnurl-1e542d031dc565ae2d808b98413613dda77bf646.zip
configure.ac: Add patch from pkgsrc for gssapi suport, though we should remove
this in the future due to gssapi not being a goal here.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac10
1 files changed, 7 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 04f9b23c5..4dd17945c 100755
--- a/configure.ac
+++ b/configure.ac
@@ -1266,7 +1266,7 @@ dnl **********************************************************************
dnl Check for GSS-API libraries
dnl **********************************************************************
-dnl check for GSS-API stuff in the /usr as default
+dnl check for GSS-API stuff in the /usr as default. Note: possible candidate for removal.
GSSAPI_ROOT="/usr"
AC_ARG_WITH(gssapi-includes,
@@ -1307,7 +1307,11 @@ if test x"$want_gss" = xyes; then
if test -n "$host_alias" -a -f "$GSSAPI_ROOT/bin/$host_alias-krb5-config"; then
GSSAPI_INCS=`$GSSAPI_ROOT/bin/$host_alias-krb5-config --cflags gssapi`
elif test -f "$KRB5CONFIG"; then
- GSSAPI_INCS=`$KRB5CONFIG --cflags gssapi`
+ if `$KRB5CONFIG --cflags gssapi 2>&1 | grep "Unknown option" >/dev/null; then
+ GSSAPI_INCS=`$KRB5CONFIG --cflags`
+ else
+ GSSAPI_INCS=`$KRB5CONFIG --cflags gssapi`
+ fi
elif test "$GSSAPI_ROOT" != "yes"; then
GSSAPI_INCS="-I$GSSAPI_ROOT/include"
fi
@@ -1428,7 +1432,7 @@ if test x"$want_gss" = xyes; then
LIBS="lgss $LIBS"
;;
*)
- LIBS="-lgssapi $LIBS"
+ LIBS="-lgssapi -lkrb5 $LIBS"
;;
esac
fi