summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorng0 <ng0@n0.is>2018-01-21 22:37:57 +0000
committerng0 <ng0@n0.is>2018-01-21 22:37:57 +0000
commitcc5f34a99383aa99937d545f25eb1eb8cabe2ca1 (patch)
treef295bd95086d293679d9d4f0a97ce66c66dc2137 /configure.ac
parent851483824fd0071cc8ac5454c475a90dfcb5f6c5 (diff)
parent9d82cde7b2bd839600041b9ca1f2f743cce23df2 (diff)
downloadgnurl-cc5f34a99383aa99937d545f25eb1eb8cabe2ca1.tar.gz
gnurl-cc5f34a99383aa99937d545f25eb1eb8cabe2ca1.tar.bz2
gnurl-cc5f34a99383aa99937d545f25eb1eb8cabe2ca1.zip
Merge branch 'master' of https://github.com/curl/curl
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac471
1 files changed, 467 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index eae012514..34777f229 100755
--- a/configure.ac
+++ b/configure.ac
@@ -51,7 +51,6 @@ CURL_CHECK_OPTION_ARES
CURL_CHECK_OPTION_RT
XC_CHECK_PATH_SEPARATOR
-AX_CODE_COVERAGE
#
# save the configure arguments
@@ -124,6 +123,13 @@ AC_SUBST(libext)
dnl figure out the libcurl version
CURLVERSION=`$SED -ne 's/^#define LIBCURL_VERSION "\(.*\)".*/\1/p' ${srcdir}/include/gnurl/curlver.h`
XC_CHECK_PROG_CC
+
+dnl Check if gcc is being used before adding AX_CODE_COVERAGE
+AS_IF([ test "$GCC" = "yes" ], [AX_CODE_COVERAGE],
+ # not using GCC so pass a test below - CODE_COVERAGE_ENABLED_TRUE is not zero length
+ CODE_COVERAGE_ENABLED_TRUE='#'
+)
+
XC_AUTOMAKE
AC_MSG_CHECKING([curl version])
AC_MSG_RESULT($CURLVERSION)
@@ -1199,6 +1205,9 @@ if test "$ipv6" = yes; then
#include <ws2tcpip.h>
#else
#include <netinet/in.h>
+#if defined (__TANDEM)
+# include <netinet/in6.h>
+#endif
#endif] ,
struct sockaddr_in6 s; s.sin6_scope_id = 0; , have_sin6_scope_id=yes)
if test "$have_sin6_scope_id" = yes; then
@@ -1467,6 +1476,296 @@ dnl Default to no CA bundle
ca="no"
dnl Set Default to 0:
dnl OPENSSL_ENABLED="0"
+dnl AC_ARG_WITH(ssl,dnl
+dnl AC_HELP_STRING([--with-ssl=PATH],[Where to look for OpenSSL, PATH points to the SSL installation (default: /usr/local/ssl); when possible, set the PKG_CONFIG_PATH environment variable instead of using this option])
+dnl AC_HELP_STRING([--without-ssl], [disable OpenSSL]),
+dnl OPT_SSL=$withval)
+
+dnl if test -z "$ssl_backends" -o "x$OPT_SSL" != xno &&
+dnl test X"$OPT_SSL" != Xno; then
+dnl ssl_msg=
+
+dnl dnl backup the pre-ssl variables
+dnl CLEANLDFLAGS="$LDFLAGS"
+dnl CLEANCPPFLAGS="$CPPFLAGS"
+dnl CLEANLIBS="$LIBS"
+
+dnl dnl This is for Msys/Mingw
+dnl case $host in
+dnl *-*-msys* | *-*-mingw*)
+dnl AC_MSG_CHECKING([for gdi32])
+dnl my_ac_save_LIBS=$LIBS
+dnl LIBS="-lgdi32 $LIBS"
+dnl AC_TRY_LINK([#include <windef.h>
+dnl #include <wingdi.h>],
+dnl [GdiFlush();],
+dnl [ dnl worked!
+dnl AC_MSG_RESULT([yes])],
+dnl [ dnl failed, restore LIBS
+dnl LIBS=$my_ac_save_LIBS
+dnl AC_MSG_RESULT(no)]
+dnl )
+dnl ;;
+dnl esac
+
+dnl case "$OPT_SSL" in
+dnl yes)
+dnl dnl --with-ssl (without path) used
+dnl if test x$cross_compiling != xyes; then
+dnl dnl only do pkg-config magic when not cross-compiling
+dnl PKGTEST="yes"
+dnl fi
+dnl PREFIX_OPENSSL=/usr/local/ssl
+dnl LIB_OPENSSL="$PREFIX_OPENSSL/lib$libsuff"
+dnl ;;
+dnl off)
+dnl dnl no --with-ssl option given, just check default places
+dnl if test x$cross_compiling != xyes; then
+dnl dnl only do pkg-config magic when not cross-compiling
+dnl PKGTEST="yes"
+dnl fi
+dnl PREFIX_OPENSSL=
+dnl ;;
+dnl *)
+dnl dnl check the given --with-ssl spot
+dnl PKGTEST="no"
+dnl PREFIX_OPENSSL=$OPT_SSL
+
+dnl dnl Try pkg-config even when cross-compiling. Since we
+dnl dnl specify PKG_CONFIG_LIBDIR we're only looking where
+dnl dnl the user told us to look
+dnl OPENSSL_PCDIR="$OPT_SSL/lib/pkgconfig"
+dnl AC_MSG_NOTICE([PKG_CONFIG_LIBDIR will be set to "$OPENSSL_PCDIR"])
+dnl if test -f "$OPENSSL_PCDIR/openssl.pc"; then
+dnl PKGTEST="yes"
+dnl fi
+
+dnl dnl in case pkg-config comes up empty, use what we got
+dnl dnl via --with-ssl
+dnl LIB_OPENSSL="$PREFIX_OPENSSL/lib$libsuff"
+dnl if test "$PREFIX_OPENSSL" != "/usr" ; then
+dnl SSL_LDFLAGS="-L$LIB_OPENSSL"
+dnl SSL_CPPFLAGS="-I$PREFIX_OPENSSL/include"
+dnl fi
+dnl SSL_CPPFLAGS="$SSL_CPPFLAGS -I$PREFIX_OPENSSL/include/openssl"
+dnl ;;
+dnl esac
+
+dnl if test "$PKGTEST" = "yes"; then
+
+dnl CURL_CHECK_PKGCONFIG(openssl, [$OPENSSL_PCDIR])
+
+dnl if test "$PKGCONFIG" != "no" ; then
+dnl SSL_LIBS=`CURL_EXPORT_PCDIR([$OPENSSL_PCDIR]) dnl
+dnl $PKGCONFIG --libs-only-l openssl 2>/dev/null`
+
+dnl SSL_LDFLAGS=`CURL_EXPORT_PCDIR([$OPENSSL_PCDIR]) dnl
+dnl $PKGCONFIG --libs-only-L openssl 2>/dev/null`
+
+dnl SSL_CPPFLAGS=`CURL_EXPORT_PCDIR([$OPENSSL_PCDIR]) dnl
+dnl $PKGCONFIG --cflags-only-I openssl 2>/dev/null`
+
+dnl AC_SUBST(SSL_LIBS)
+dnl AC_MSG_NOTICE([pkg-config: SSL_LIBS: "$SSL_LIBS"])
+dnl AC_MSG_NOTICE([pkg-config: SSL_LDFLAGS: "$SSL_LDFLAGS"])
+dnl AC_MSG_NOTICE([pkg-config: SSL_CPPFLAGS: "$SSL_CPPFLAGS"])
+
+dnl LIB_OPENSSL=`echo $SSL_LDFLAGS | sed -e 's/-L//g'`
+
+dnl dnl use the values pkg-config reported. This is here
+dnl dnl instead of below with CPPFLAGS and LDFLAGS because we only
+dnl dnl learn about this via pkg-config. If we only have
+dnl dnl the argument to --with-ssl we don't know what
+dnl dnl additional libs may be necessary. Hope that we
+dnl dnl don't need any.
+dnl LIBS="$SSL_LIBS $LIBS"
+dnl fi
+dnl fi
+
+dnl dnl finally, set flags to use SSL
+dnl CPPFLAGS="$CPPFLAGS $SSL_CPPFLAGS"
+dnl LDFLAGS="$LDFLAGS $SSL_LDFLAGS"
+
+dnl AC_CHECK_LIB(crypto, HMAC_Update,[
+dnl HAVECRYPTO="yes"
+dnl LIBS="-lcrypto $LIBS"
+dnl ],[
+dnl LDFLAGS="$CLEANLDFLAGS -L$LIB_OPENSSL"
+dnl CPPFLAGS="$CLEANCPPFLAGS -I$PREFIX_OPENSSL/include/openssl -I$PREFIX_OPENSSL/include"
+dnl AC_CHECK_LIB(crypto, HMAC_Init_ex,[
+dnl HAVECRYPTO="yes"
+dnl LIBS="-lcrypto $LIBS"], [
+
+dnl dnl still no, but what about with -ldl?
+dnl AC_MSG_CHECKING([OpenSSL linking with -ldl])
+dnl LIBS="$LIBS -ldl"
+dnl AC_TRY_LINK(
+dnl [
+dnl #include <openssl/err.h>
+dnl ],
+dnl [
+dnl ERR_clear_error();
+dnl ],
+dnl [
+dnl AC_MSG_RESULT(yes)
+dnl HAVECRYPTO="yes"
+dnl ],
+dnl [
+dnl AC_MSG_RESULT(no)
+dnl dnl ok, so what about bouth -ldl and -lpthread?
+
+dnl AC_MSG_CHECKING([OpenSSL linking with -ldl and -lpthread])
+dnl LIBS="$LIBS -lpthread"
+dnl AC_TRY_LINK(
+dnl [
+dnl #include <openssl/err.h>
+dnl ],
+dnl [
+dnl ERR_clear_error();
+dnl ],
+dnl [
+dnl AC_MSG_RESULT(yes)
+dnl HAVECRYPTO="yes"
+dnl ],
+dnl [
+dnl AC_MSG_RESULT(no)
+dnl LDFLAGS="$CLEANLDFLAGS"
+dnl CPPFLAGS="$CLEANCPPFLAGS"
+dnl LIBS="$CLEANLIBS"
+
+dnl ])
+
+dnl ])
+
+dnl ])
+dnl ])
+
+dnl if test X"$HAVECRYPTO" = X"yes"; then
+dnl dnl This is only reasonable to do if crypto actually is there: check for
+dnl dnl SSL libs NOTE: it is important to do this AFTER the crypto lib
+
+dnl AC_CHECK_LIB(ssl, SSL_connect)
+
+dnl if test "$ac_cv_lib_ssl_SSL_connect" != yes; then
+dnl dnl we didn't find the SSL lib, try the RSAglue/rsaref stuff
+dnl AC_MSG_CHECKING(for ssl with RSAglue/rsaref libs in use);
+dnl OLIBS=$LIBS
+dnl LIBS="-lRSAglue -lrsaref $LIBS"
+dnl AC_CHECK_LIB(ssl, SSL_connect)
+dnl if test "$ac_cv_lib_ssl_SSL_connect" != yes; then
+dnl dnl still no SSL_connect
+dnl AC_MSG_RESULT(no)
+dnl LIBS=$OLIBS
+dnl else
+dnl AC_MSG_RESULT(yes)
+dnl fi
+
+dnl else
+
+dnl dnl Have the libraries--check for OpenSSL headers
+dnl AC_CHECK_HEADERS(openssl/x509.h openssl/rsa.h openssl/crypto.h \
+dnl openssl/pem.h openssl/ssl.h openssl/err.h,
+dnl ssl_msg="OpenSSL"
+dnl test openssl != "$DEFAULT_SSL_BACKEND" || VALID_DEFAULT_SSL_BACKEND=yes
+dnl OPENSSL_ENABLED=1
+dnl AC_DEFINE(USE_OPENSSL, 1, [if OpenSSL is in use]))
+
+dnl if test $ac_cv_header_openssl_x509_h = no; then
+dnl dnl we don't use the "action" part of the AC_CHECK_HEADERS macro
+dnl dnl since 'err.h' might in fact find a krb4 header with the same
+dnl dnl name
+dnl AC_CHECK_HEADERS(x509.h rsa.h crypto.h pem.h ssl.h err.h)
+
+dnl if test $ac_cv_header_x509_h = yes &&
+dnl test $ac_cv_header_crypto_h = yes &&
+dnl test $ac_cv_header_ssl_h = yes; then
+dnl dnl three matches
+dnl ssl_msg="OpenSSL"
+dnl OPENSSL_ENABLED=1
+dnl fi
+dnl fi
+dnl fi
+
+dnl if test X"$OPENSSL_ENABLED" != X"1"; then
+dnl LIBS="$CLEANLIBS"
+dnl fi
+
+dnl if test X"$OPT_SSL" != Xoff &&
+dnl test "$OPENSSL_ENABLED" != "1"; then
+dnl AC_MSG_ERROR([OpenSSL libs and/or directories were not found where specified!])
+dnl fi
+dnl fi
+
+dnl if test X"$OPENSSL_ENABLED" = X"1"; then
+dnl dnl If the ENGINE library seems to be around, check for the OpenSSL engine
+dnl dnl stuff, it is kind of "separated" from the main SSL check
+dnl AC_CHECK_FUNC(ENGINE_init,
+dnl [
+dnl AC_CHECK_HEADERS(openssl/engine.h)
+dnl AC_CHECK_FUNCS( ENGINE_load_builtin_engines )
+dnl ])
+
+dnl dnl These can only exist if OpenSSL exists
+dnl dnl Older versions of Cyassl (some time before 2.9.4) don't have
+dnl dnl SSL_get_shutdown (but this check won't actually detect it there
+dnl dnl as it's a macro that needs the header files be included)
+
+dnl AC_CHECK_FUNCS( RAND_egd \
+dnl ENGINE_cleanup \
+dnl SSL_get_shutdown \
+dnl SSLv2_client_method )
+
+dnl AC_MSG_CHECKING([for BoringSSL])
+dnl AC_COMPILE_IFELSE([
+dnl AC_LANG_PROGRAM([[
+dnl #include <openssl/base.h>
+dnl ]],[[
+dnl #ifndef OPENSSL_IS_BORINGSSL
+dnl #error not boringssl
+dnl #endif
+dnl ]])
+dnl ],[
+dnl AC_MSG_RESULT([yes])
+dnl AC_DEFINE_UNQUOTED(HAVE_BORINGSSL, 1,
+dnl [Define to 1 if using BoringSSL.])
+dnl ssl_msg="BoringSSL"
+dnl ],[
+dnl AC_MSG_RESULT([no])
+dnl ])
+
+dnl AC_MSG_CHECKING([for libressl])
+dnl AC_COMPILE_IFELSE([
+dnl AC_LANG_PROGRAM([[
+dnl #include <openssl/opensslv.h>
+dnl ]],[[
+dnl int dummy = LIBRESSL_VERSION_NUMBER;
+dnl ]])
+dnl ],[
+dnl AC_MSG_RESULT([yes])
+dnl AC_DEFINE_UNQUOTED(HAVE_LIBRESSL, 1,
+dnl [Define to 1 if using libressl.])
+dnl ssl_msg="libressl"
+dnl ],[
+dnl AC_MSG_RESULT([no])
+dnl ])
+dnl fi
+
+dnl if test "$OPENSSL_ENABLED" = "1"; then
+dnl if test -n "$LIB_OPENSSL"; then
+dnl dnl when the ssl shared libs were found in a path that the run-time
+dnl dnl linker doesn't search through, we need to add it to LD_LIBRARY_PATH
+dnl dnl to prevent further configure tests to fail due to this
+dnl if test "x$cross_compiling" != "xyes"; then
+dnl LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$LIB_OPENSSL"
+dnl export LD_LIBRARY_PATH
+dnl AC_MSG_NOTICE([Added $LIB_OPENSSL to LD_LIBRARY_PATH])
+dnl fi
+dnl fi
+dnl CURL_CHECK_OPENSSL_API
+dnl fi
+
+dnl test -z "$ssl_msg" || ssl_backends="${ssl_backends:+$ssl_backends, }$ssl_msg"
+dnl fi
dnl **********************************************************************
dnl Check for the random seed preferences
@@ -1866,10 +2165,164 @@ dnl Default to compiler & linker defaults for LIBSSH2 files & libraries.
OPT_LIBSSH2=off
AC_ARG_WITH(libssh2,dnl
AC_HELP_STRING([--with-libssh2=PATH],[Where to look for libssh2, PATH points to the LIBSSH2 installation; when possible, set the PKG_CONFIG_PATH environment variable instead of using this option])
-AC_HELP_STRING([--without-libssh2], [disable LIBSSH2]),
- OPT_LIBSSH2=$withval)
+AC_HELP_STRING([--with-libssh2], [enable LIBSSH2]),
+ OPT_LIBSSH2=$withval, OPT_LIBSSH2=no)
+
+
+OPT_LIBSSH=off
+AC_ARG_WITH(libssh,dnl
+AC_HELP_STRING([--with-libssh=PATH],[Where to look for libssh, PATH points to the LIBSSH installation; when possible, set the PKG_CONFIG_PATH environment variable instead of using this option])
+AC_HELP_STRING([--with-libssh], [enable LIBSSH]),
+ OPT_LIBSSH=$withval, OPT_LIBSSH=no)
LIBSSH2_ENABLED="0"
+dnl if test X"$OPT_LIBSSH2" != Xno; then
+dnl dnl backup the pre-libssh2 variables
+dnl CLEANLDFLAGS="$LDFLAGS"
+dnl CLEANCPPFLAGS="$CPPFLAGS"
+dnl CLEANLIBS="$LIBS"
+
+dnl case "$OPT_LIBSSH2" in
+dnl yes)
+dnl dnl --with-libssh2 (without path) used
+dnl CURL_CHECK_PKGCONFIG(libssh2)
+
+dnl if test "$PKGCONFIG" != "no" ; then
+dnl LIB_SSH2=`$PKGCONFIG --libs-only-l libssh2`
+dnl LD_SSH2=`$PKGCONFIG --libs-only-L libssh2`
+dnl CPP_SSH2=`$PKGCONFIG --cflags-only-I libssh2`
+dnl version=`$PKGCONFIG --modversion libssh2`
+dnl DIR_SSH2=`echo $LD_SSH2 | $SED -e 's/-L//'`
+dnl fi
+
+dnl ;;
+dnl off)
+dnl dnl no --with-libssh2 option given, just check default places
+dnl ;;
+dnl *)
+dnl dnl use the given --with-libssh2 spot
+dnl PREFIX_SSH2=$OPT_LIBSSH2
+dnl ;;
+dnl esac
+
+dnl dnl if given with a prefix, we set -L and -I based on that
+dnl if test -n "$PREFIX_SSH2"; then
+dnl LIB_SSH2="-lssh2"
+dnl LD_SSH2=-L${PREFIX_SSH2}/lib$libsuff
+dnl CPP_SSH2=-I${PREFIX_SSH2}/include
+dnl DIR_SSH2=${PREFIX_SSH2}/lib$libsuff
+dnl fi
+
+dnl LDFLAGS="$LDFLAGS $LD_SSH2"
+dnl CPPFLAGS="$CPPFLAGS $CPP_SSH2"
+dnl LIBS="$LIB_SSH2 $LIBS"
+
+dnl AC_CHECK_LIB(ssh2, libssh2_channel_open_ex)
+
+dnl AC_CHECK_HEADERS(libssh2.h,
+dnl curl_ssh_msg="enabled (libSSH2)"
+dnl LIBSSH2_ENABLED=1
+dnl AC_DEFINE(USE_LIBSSH2, 1, [if libSSH2 is in use])
+dnl AC_SUBST(USE_LIBSSH2, [1])
+dnl )
+
+dnl if test X"$OPT_LIBSSH2" != Xoff &&
+dnl test "$LIBSSH2_ENABLED" != "1"; then
+dnl AC_MSG_ERROR([libSSH2 libs and/or directories were not found where specified!])
+dnl fi
+
+dnl if test "$LIBSSH2_ENABLED" = "1"; then
+dnl if test -n "$DIR_SSH2"; then
+dnl dnl when the libssh2 shared libs were found in a path that the run-time
+dnl dnl linker doesn't search through, we need to add it to LD_LIBRARY_PATH
+dnl dnl to prevent further configure tests to fail due to this
+
+dnl if test "x$cross_compiling" != "xyes"; then
+dnl LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$DIR_SSH2"
+dnl export LD_LIBRARY_PATH
+dnl AC_MSG_NOTICE([Added $DIR_SSH2 to LD_LIBRARY_PATH])
+dnl fi
+dnl fi
+dnl else
+dnl dnl no libssh2, revert back to clean variables
+dnl LDFLAGS=$CLEANLDFLAGS
+dnl CPPFLAGS=$CLEANCPPFLAGS
+dnl LIBS=$CLEANLIBS
+dnl fi
+dnl elif test X"$OPT_LIBSSH" != Xno; then
+dnl dnl backup the pre-libssh variables
+dnl CLEANLDFLAGS="$LDFLAGS"
+dnl CLEANCPPFLAGS="$CPPFLAGS"
+dnl CLEANLIBS="$LIBS"
+
+dnl case "$OPT_LIBSSH" in
+dnl yes)
+dnl dnl --with-libssh (without path) used
+dnl CURL_CHECK_PKGCONFIG(libssh)
+
+dnl if test "$PKGCONFIG" != "no" ; then
+dnl LIB_SSH=`$PKGCONFIG --libs-only-l libssh`
+dnl LD_SSH=`$PKGCONFIG --libs-only-L libssh`
+dnl CPP_SSH=`$PKGCONFIG --cflags-only-I libssh`
+dnl version=`$PKGCONFIG --modversion libssh`
+dnl DIR_SSH=`echo $LD_SSH | $SED -e 's/-L//'`
+dnl fi
+
+dnl ;;
+dnl off)
+dnl dnl no --with-libssh option given, just check default places
+dnl ;;
+dnl *)
+dnl dnl use the given --with-libssh spot
+dnl PREFIX_SSH=$OPT_LIBSSH
+dnl ;;
+dnl esac
+
+dnl dnl if given with a prefix, we set -L and -I based on that
+dnl if test -n "$PREFIX_SSH"; then
+dnl LIB_SSH="-lssh"
+dnl LD_SSH=-L${PREFIX_SSH}/lib$libsuff
+dnl CPP_SSH=-I${PREFIX_SSH}/include
+dnl DIR_SSH=${PREFIX_SSH}/lib$libsuff
+dnl fi
+
+dnl LDFLAGS="$LDFLAGS $LD_SSH"
+dnl CPPFLAGS="$CPPFLAGS $CPP_SSH"
+dnl LIBS="$LIB_SSH $LIBS"
+
+dnl AC_CHECK_LIB(ssh, ssh_new)
+
+dnl AC_CHECK_HEADERS(libssh/libssh.h,
+dnl curl_ssh_msg="enabled (libSSH)"
+dnl LIBSSH_ENABLED=1
+dnl AC_DEFINE(USE_LIBSSH, 1, [if libSSH is in use])
+dnl AC_SUBST(USE_LIBSSH, [1])
+dnl )
+
+dnl if test X"$OPT_LIBSSH" != Xoff &&
+dnl test "$LIBSSH_ENABLED" != "1"; then
+dnl AC_MSG_ERROR([libSSH libs and/or directories were not found where specified!])
+dnl fi
+
+dnl if test "$LIBSSH_ENABLED" = "1"; then
+dnl if test -n "$DIR_SSH"; then
+dnl dnl when the libssh shared libs were found in a path that the run-time
+dnl dnl linker doesn't search through, we need to add it to LD_LIBRARY_PATH
+dnl dnl to prevent further configure tests to fail due to this
+
+dnl if test "x$cross_compiling" != "xyes"; then
+dnl LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$DIR_SSH"
+dnl export LD_LIBRARY_PATH
+dnl AC_MSG_NOTICE([Added $DIR_SSH to LD_LIBRARY_PATH])
+dnl fi
+dnl fi
+dnl else
+dnl dnl no libssh, revert back to clean variables
+dnl LDFLAGS=$CLEANLDFLAGS
+dnl CPPFLAGS=$CLEANCPPFLAGS
+dnl LIBS=$CLEANLIBS
+dnl fi
+dnl fi
dnl **********************************************************************
dnl Check for the presence of LIBRTMP libraries and headers
@@ -2226,10 +2679,10 @@ AC_CHECK_HEADERS(
assert.h \
unistd.h \
stdlib.h \
- limits.h \
arpa/inet.h \
net/if.h \
netinet/in.h \
+ netinet/in6.h \
sys/un.h \
linux/tcp.h \
netinet/tcp.h \
@@ -2280,6 +2733,9 @@ dnl default includes
#ifdef HAVE_NETINET_IN_H
#include <netinet/in.h>
#endif
+#ifdef HAVE_NETINET_IN6_H
+#include <netinet/in6.h>
+#endif
#ifdef HAVE_SYS_UN_H
#include <sys/un.h>
#endif
@@ -2964,6 +3420,10 @@ if test "x$USE_LIBSSH2" = "x1"; then
SUPPORT_PROTOCOLS="$SUPPORT_PROTOCOLS SCP"
SUPPORT_PROTOCOLS="$SUPPORT_PROTOCOLS SFTP"
fi
+if test "x$USE_LIBSSH" = "x1"; then
+ SUPPORT_PROTOCOLS="$SUPPORT_PROTOCOLS SCP"
+ SUPPORT_PROTOCOLS="$SUPPORT_PROTOCOLS SFTP"
+fi
if test "x$CURL_DISABLE_RTSP" != "x1"; then
SUPPORT_PROTOCOLS="$SUPPORT_PROTOCOLS RTSP"
fi
@@ -2995,6 +3455,9 @@ squeeze SUPPORT_PROTOCOLS
XC_CHECK_BUILD_FLAGS
+SSL_BACKENDS=${ssl_backends}
+AC_SUBST(SSL_BACKENDS)
+
if test "x$want_curldebug_assumed" = "xyes" &&
test "x$want_curldebug" = "xyes" && test "x$USE_ARES" = "x1"; then
ac_configure_args="$ac_configure_args --enable-curldebug"