summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNils Gillmann <gillmann@gnunet.org>2018-05-23 10:24:02 +0000
committerNils Gillmann <gillmann@gnunet.org>2018-05-23 10:24:02 +0000
commit97f0e8cf8585325401b9d19e433131722f978984 (patch)
tree935fa45929a646222b5abdd260a7bfd4be2cd836 /configure.ac
parent422f18ebe7ad2cbcd5d45ed05ae02e959e4a7d8b (diff)
parentcb013830383f1ccc9757aba36bc32df5ec281c02 (diff)
downloadgnurl-97f0e8cf8585325401b9d19e433131722f978984.tar.gz
gnurl-97f0e8cf8585325401b9d19e433131722f978984.tar.bz2
gnurl-97f0e8cf8585325401b9d19e433131722f978984.zip
Merge tag 'curl-7_60_0' (with fixes)
curl 7.60.0 Signed-off-by: Nils Gillmann <gillmann@gnunet.org>
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac499
1 files changed, 40 insertions, 459 deletions
diff --git a/configure.ac b/configure.ac
index f946bb5b6..dd9cb1590 100755
--- a/configure.ac
+++ b/configure.ac
@@ -1046,13 +1046,13 @@ if test X"$OPT_BROTLI" != Xno; then
if test "$HAVE_BROTLI" = "1"; then
if test -n "$DIR_BROTLI"; then
dnl when the brotli shared libs were found in a path that the run-time
- dnl linker doesn't search through, we need to add it to LD_LIBRARY_PATH
+ dnl linker doesn't search through, we need to add it to CURL_LIBRARY_PATH
dnl to prevent further configure tests to fail due to this
if test "x$cross_compiling" != "xyes"; then
- LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$DIR_BROTLI"
- export LD_LIBRARY_PATH
- AC_MSG_NOTICE([Added $DIR_BROTLI to LD_LIBRARY_PATH])
+ CURL_LIBRARY_PATH="$CURL_LIBRARY_PATH:$DIR_BROTLI"
+ export CURL_LIBRARY_PATH
+ AC_MSG_NOTICE([Added $DIR_BROTLI to CURL_LIBRARY_PATH])
fi
fi
else
@@ -1223,13 +1223,11 @@ dnl Check if the operating system allows programs to write to their own argv[]
dnl **********************************************************************
AC_MSG_CHECKING([if argv can be written to])
-AC_RUN_IFELSE([
- AC_LANG_SOURCE([[
+CURL_RUN_IFELSE([
int main(int argc, char ** argv) {
argv[0][0] = ' ';
return (argv[0][0] == ' ')?0:1;
}
- ]])
],[
curl_cv_writable_argv=yes
],[
@@ -1474,298 +1472,6 @@ dnl Default to compiler & linker defaults for SSL files & libraries.
OPT_SSL=off
dnl Default to no CA bundle
ca="no"
-dnl Set Default to 0:
-dnl OPENSSL_ENABLED="0"
-dnl AC_ARG_WITH(ssl,dnl
-dnl AC_HELP_STRING([--with-ssl=PATH],[Where to look for OpenSSL, PATH points to the SSL installation (default: /usr/local/ssl); when possible, set the PKG_CONFIG_PATH environment variable instead of using this option])
-dnl AC_HELP_STRING([--without-ssl], [disable OpenSSL]),
-dnl OPT_SSL=$withval)
-
-dnl if test -z "$ssl_backends" -o "x$OPT_SSL" != xno &&
-dnl test X"$OPT_SSL" != Xno; then
-dnl ssl_msg=
-
-dnl dnl backup the pre-ssl variables
-dnl CLEANLDFLAGS="$LDFLAGS"
-dnl CLEANCPPFLAGS="$CPPFLAGS"
-dnl CLEANLIBS="$LIBS"
-
-dnl dnl This is for Msys/Mingw
-dnl case $host in
-dnl *-*-msys* | *-*-mingw*)
-dnl AC_MSG_CHECKING([for gdi32])
-dnl my_ac_save_LIBS=$LIBS
-dnl LIBS="-lgdi32 $LIBS"
-dnl AC_TRY_LINK([#include <windef.h>
-dnl #include <wingdi.h>],
-dnl [GdiFlush();],
-dnl [ dnl worked!
-dnl AC_MSG_RESULT([yes])],
-dnl [ dnl failed, restore LIBS
-dnl LIBS=$my_ac_save_LIBS
-dnl AC_MSG_RESULT(no)]
-dnl )
-dnl ;;
-dnl esac
-
-dnl case "$OPT_SSL" in
-dnl yes)
-dnl dnl --with-ssl (without path) used
-dnl if test x$cross_compiling != xyes; then
-dnl dnl only do pkg-config magic when not cross-compiling
-dnl PKGTEST="yes"
-dnl fi
-dnl PREFIX_OPENSSL=/usr/local/ssl
-dnl LIB_OPENSSL="$PREFIX_OPENSSL/lib$libsuff"
-dnl ;;
-dnl off)
-dnl dnl no --with-ssl option given, just check default places
-dnl if test x$cross_compiling != xyes; then
-dnl dnl only do pkg-config magic when not cross-compiling
-dnl PKGTEST="yes"
-dnl fi
-dnl PREFIX_OPENSSL=
-dnl ;;
-dnl *)
-dnl dnl check the given --with-ssl spot
-dnl PKGTEST="no"
-dnl PREFIX_OPENSSL=$OPT_SSL
-
-dnl dnl Try pkg-config even when cross-compiling. Since we
-dnl dnl specify PKG_CONFIG_LIBDIR we're only looking where
-dnl dnl the user told us to look
-dnl OPENSSL_PCDIR="$OPT_SSL/lib/pkgconfig"
-dnl AC_MSG_NOTICE([PKG_CONFIG_LIBDIR will be set to "$OPENSSL_PCDIR"])
-dnl if test -f "$OPENSSL_PCDIR/openssl.pc"; then
-dnl PKGTEST="yes"
-dnl fi
-
-dnl dnl in case pkg-config comes up empty, use what we got
-dnl dnl via --with-ssl
-dnl LIB_OPENSSL="$PREFIX_OPENSSL/lib$libsuff"
-dnl if test "$PREFIX_OPENSSL" != "/usr" ; then
-dnl SSL_LDFLAGS="-L$LIB_OPENSSL"
-dnl SSL_CPPFLAGS="-I$PREFIX_OPENSSL/include"
-dnl fi
-dnl SSL_CPPFLAGS="$SSL_CPPFLAGS -I$PREFIX_OPENSSL/include/openssl"
-dnl ;;
-dnl esac
-
-dnl if test "$PKGTEST" = "yes"; then
-
-dnl CURL_CHECK_PKGCONFIG(openssl, [$OPENSSL_PCDIR])
-
-dnl if test "$PKGCONFIG" != "no" ; then
-dnl SSL_LIBS=`CURL_EXPORT_PCDIR([$OPENSSL_PCDIR]) dnl
-dnl $PKGCONFIG --libs-only-l openssl 2>/dev/null`
-
-dnl SSL_LDFLAGS=`CURL_EXPORT_PCDIR([$OPENSSL_PCDIR]) dnl
-dnl $PKGCONFIG --libs-only-L openssl 2>/dev/null`
-
-dnl SSL_CPPFLAGS=`CURL_EXPORT_PCDIR([$OPENSSL_PCDIR]) dnl
-dnl $PKGCONFIG --cflags-only-I openssl 2>/dev/null`
-
-dnl AC_SUBST(SSL_LIBS)
-dnl AC_MSG_NOTICE([pkg-config: SSL_LIBS: "$SSL_LIBS"])
-dnl AC_MSG_NOTICE([pkg-config: SSL_LDFLAGS: "$SSL_LDFLAGS"])
-dnl AC_MSG_NOTICE([pkg-config: SSL_CPPFLAGS: "$SSL_CPPFLAGS"])
-
-dnl LIB_OPENSSL=`echo $SSL_LDFLAGS | sed -e 's/-L//g'`
-
-dnl dnl use the values pkg-config reported. This is here
-dnl dnl instead of below with CPPFLAGS and LDFLAGS because we only
-dnl dnl learn about this via pkg-config. If we only have
-dnl dnl the argument to --with-ssl we don't know what
-dnl dnl additional libs may be necessary. Hope that we
-dnl dnl don't need any.
-dnl LIBS="$SSL_LIBS $LIBS"
-dnl fi
-dnl fi
-
-dnl dnl finally, set flags to use SSL
-dnl CPPFLAGS="$CPPFLAGS $SSL_CPPFLAGS"
-dnl LDFLAGS="$LDFLAGS $SSL_LDFLAGS"
-
-dnl AC_CHECK_LIB(crypto, HMAC_Update,[
-dnl HAVECRYPTO="yes"
-dnl LIBS="-lcrypto $LIBS"
-dnl ],[
-dnl LDFLAGS="$CLEANLDFLAGS -L$LIB_OPENSSL"
-dnl CPPFLAGS="$CLEANCPPFLAGS -I$PREFIX_OPENSSL/include/openssl -I$PREFIX_OPENSSL/include"
-dnl AC_CHECK_LIB(crypto, HMAC_Init_ex,[
-dnl HAVECRYPTO="yes"
-dnl LIBS="-lcrypto $LIBS"], [
-
-dnl dnl still no, but what about with -ldl?
-dnl AC_MSG_CHECKING([OpenSSL linking with -ldl])
-dnl LIBS="$LIBS -ldl"
-dnl AC_TRY_LINK(
-dnl [
-dnl #include <openssl/err.h>
-dnl ],
-dnl [
-dnl ERR_clear_error();
-dnl ],
-dnl [
-dnl AC_MSG_RESULT(yes)
-dnl HAVECRYPTO="yes"
-dnl ],
-dnl [
-dnl AC_MSG_RESULT(no)
-dnl dnl ok, so what about bouth -ldl and -lpthread?
-
-dnl AC_MSG_CHECKING([OpenSSL linking with -ldl and -lpthread])
-dnl LIBS="$LIBS -lpthread"
-dnl AC_TRY_LINK(
-dnl [
-dnl #include <openssl/err.h>
-dnl ],
-dnl [
-dnl ERR_clear_error();
-dnl ],
-dnl [
-dnl AC_MSG_RESULT(yes)
-dnl HAVECRYPTO="yes"
-dnl ],
-dnl [
-dnl AC_MSG_RESULT(no)
-dnl LDFLAGS="$CLEANLDFLAGS"
-dnl CPPFLAGS="$CLEANCPPFLAGS"
-dnl LIBS="$CLEANLIBS"
-
-dnl ])
-
-dnl ])
-
-dnl ])
-dnl ])
-
-dnl if test X"$HAVECRYPTO" = X"yes"; then
-dnl dnl This is only reasonable to do if crypto actually is there: check for
-dnl dnl SSL libs NOTE: it is important to do this AFTER the crypto lib
-
-dnl AC_CHECK_LIB(ssl, SSL_connect)
-
-dnl if test "$ac_cv_lib_ssl_SSL_connect" != yes; then
-dnl dnl we didn't find the SSL lib, try the RSAglue/rsaref stuff
-dnl AC_MSG_CHECKING(for ssl with RSAglue/rsaref libs in use);
-dnl OLIBS=$LIBS
-dnl LIBS="-lRSAglue -lrsaref $LIBS"
-dnl AC_CHECK_LIB(ssl, SSL_connect)
-dnl if test "$ac_cv_lib_ssl_SSL_connect" != yes; then
-dnl dnl still no SSL_connect
-dnl AC_MSG_RESULT(no)
-dnl LIBS=$OLIBS
-dnl else
-dnl AC_MSG_RESULT(yes)
-dnl fi
-
-dnl else
-
-dnl dnl Have the libraries--check for OpenSSL headers
-dnl AC_CHECK_HEADERS(openssl/x509.h openssl/rsa.h openssl/crypto.h \
-dnl openssl/pem.h openssl/ssl.h openssl/err.h,
-dnl ssl_msg="OpenSSL"
-dnl test openssl != "$DEFAULT_SSL_BACKEND" || VALID_DEFAULT_SSL_BACKEND=yes
-dnl OPENSSL_ENABLED=1
-dnl AC_DEFINE(USE_OPENSSL, 1, [if OpenSSL is in use]))
-
-dnl if test $ac_cv_header_openssl_x509_h = no; then
-dnl dnl we don't use the "action" part of the AC_CHECK_HEADERS macro
-dnl dnl since 'err.h' might in fact find a krb4 header with the same
-dnl dnl name
-dnl AC_CHECK_HEADERS(x509.h rsa.h crypto.h pem.h ssl.h err.h)
-
-dnl if test $ac_cv_header_x509_h = yes &&
-dnl test $ac_cv_header_crypto_h = yes &&
-dnl test $ac_cv_header_ssl_h = yes; then
-dnl dnl three matches
-dnl ssl_msg="OpenSSL"
-dnl OPENSSL_ENABLED=1
-dnl fi
-dnl fi
-dnl fi
-
-dnl if test X"$OPENSSL_ENABLED" != X"1"; then
-dnl LIBS="$CLEANLIBS"
-dnl fi
-
-dnl if test X"$OPT_SSL" != Xoff &&
-dnl test "$OPENSSL_ENABLED" != "1"; then
-dnl AC_MSG_ERROR([OpenSSL libs and/or directories were not found where specified!])
-dnl fi
-dnl fi
-
-dnl if test X"$OPENSSL_ENABLED" = X"1"; then
-dnl dnl If the ENGINE library seems to be around, check for the OpenSSL engine
-dnl dnl stuff, it is kind of "separated" from the main SSL check
-dnl AC_CHECK_FUNC(ENGINE_init,
-dnl [
-dnl AC_CHECK_HEADERS(openssl/engine.h)
-dnl AC_CHECK_FUNCS( ENGINE_load_builtin_engines )
-dnl ])
-
-dnl dnl These can only exist if OpenSSL exists
-dnl dnl Older versions of Cyassl (some time before 2.9.4) don't have
-dnl dnl SSL_get_shutdown (but this check won't actually detect it there
-dnl dnl as it's a macro that needs the header files be included)
-
-dnl AC_CHECK_FUNCS( RAND_egd \
-dnl ENGINE_cleanup \
-dnl SSL_get_shutdown \
-dnl SSLv2_client_method )
-
-dnl AC_MSG_CHECKING([for BoringSSL])
-dnl AC_COMPILE_IFELSE([
-dnl AC_LANG_PROGRAM([[
-dnl #include <openssl/base.h>
-dnl ]],[[
-dnl #ifndef OPENSSL_IS_BORINGSSL
-dnl #error not boringssl
-dnl #endif
-dnl ]])
-dnl ],[
-dnl AC_MSG_RESULT([yes])
-dnl AC_DEFINE_UNQUOTED(HAVE_BORINGSSL, 1,
-dnl [Define to 1 if using BoringSSL.])
-dnl ssl_msg="BoringSSL"
-dnl ],[
-dnl AC_MSG_RESULT([no])
-dnl ])
-
-dnl AC_MSG_CHECKING([for libressl])
-dnl AC_COMPILE_IFELSE([
-dnl AC_LANG_PROGRAM([[
-dnl #include <openssl/opensslv.h>
-dnl ]],[[
-dnl int dummy = LIBRESSL_VERSION_NUMBER;
-dnl ]])
-dnl ],[
-dnl AC_MSG_RESULT([yes])
-dnl AC_DEFINE_UNQUOTED(HAVE_LIBRESSL, 1,
-dnl [Define to 1 if using libressl.])
-dnl ssl_msg="libressl"
-dnl ],[
-dnl AC_MSG_RESULT([no])
-dnl ])
-dnl fi
-
-dnl if test "$OPENSSL_ENABLED" = "1"; then
-dnl if test -n "$LIB_OPENSSL"; then
-dnl dnl when the ssl shared libs were found in a path that the run-time
-dnl dnl linker doesn't search through, we need to add it to LD_LIBRARY_PATH
-dnl dnl to prevent further configure tests to fail due to this
-dnl if test "x$cross_compiling" != "xyes"; then
-dnl LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$LIB_OPENSSL"
-dnl export LD_LIBRARY_PATH
-dnl AC_MSG_NOTICE([Added $LIB_OPENSSL to LD_LIBRARY_PATH])
-dnl fi
-dnl fi
-dnl CURL_CHECK_OPENSSL_API
-dnl fi
-
-dnl test -z "$ssl_msg" || ssl_backends="${ssl_backends:+$ssl_backends, }$ssl_msg"
-dnl fi
dnl **********************************************************************
dnl Check for the random seed preferences
@@ -1806,7 +1512,7 @@ fi
dnl ---
dnl We require OpenSSL with SRP support.
dnl ---
-if test "$OPENSSL_ENABLED" = "1"; then
+12if test "$OPENSSL_ENABLED" = "1"; then
AC_CHECK_LIB(crypto, SRP_Calc_client_key,
[
AC_DEFINE(HAVE_OPENSSL_SRP, 1, [if you have the function SRP_Calc_client_key])
@@ -1911,16 +1617,16 @@ if test -z "$ssl_backends" -o "x$OPT_GNUTLS" != xno; then
if test "x$USE_GNUTLS" = "xyes"; then
AC_MSG_NOTICE([detected GnuTLS version $version])
-
+ check_for_ca_bundle=1
if test -n "$gtlslib"; then
dnl when shared libs were found in a path that the run-time
dnl linker doesn't search through, we need to add it to
- dnl LD_LIBRARY_PATH to prevent further configure tests to fail
+ dnl CURL_LIBRARY_PATH to prevent further configure tests to fail
dnl due to this
if test "x$cross_compiling" != "xyes"; then
- LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$gtlslib"
- export LD_LIBRARY_PATH
- AC_MSG_NOTICE([Added $gtlslib to LD_LIBRARY_PATH])
+ CURL_LIBRARY_PATH="$CURL_LIBRARY_PATH:$gtlslib"
+ export CURL_LIBRARY_PATH
+ AC_MSG_NOTICE([Added $gtlslib to CURL_LIBRARY_PATH])
fi
fi
AC_CHECK_FUNCS([gnutls_certificate_set_x509_key_file2 gnutls_alpn_set_protocols gnutls_ocsp_req_init])
@@ -2046,7 +1752,9 @@ dnl **********************************************************************
dnl Check for the CA bundle
dnl **********************************************************************
-CURL_CHECK_CA_BUNDLE
+if test "$check_for_ca_bundle" -gt 0; then
+ CURL_CHECK_CA_BUNDLE
+fi
dnl **********************************************************************
dnl Check for libpsl
@@ -2176,153 +1884,6 @@ AC_HELP_STRING([--with-libssh], [enable LIBSSH]),
OPT_LIBSSH=$withval, OPT_LIBSSH=no)
LIBSSH2_ENABLED="0"
-dnl if test X"$OPT_LIBSSH2" != Xno; then
-dnl dnl backup the pre-libssh2 variables
-dnl CLEANLDFLAGS="$LDFLAGS"
-dnl CLEANCPPFLAGS="$CPPFLAGS"
-dnl CLEANLIBS="$LIBS"
-
-dnl case "$OPT_LIBSSH2" in
-dnl yes)
-dnl dnl --with-libssh2 (without path) used
-dnl CURL_CHECK_PKGCONFIG(libssh2)
-
-dnl if test "$PKGCONFIG" != "no" ; then
-dnl LIB_SSH2=`$PKGCONFIG --libs-only-l libssh2`
-dnl LD_SSH2=`$PKGCONFIG --libs-only-L libssh2`
-dnl CPP_SSH2=`$PKGCONFIG --cflags-only-I libssh2`
-dnl version=`$PKGCONFIG --modversion libssh2`
-dnl DIR_SSH2=`echo $LD_SSH2 | $SED -e 's/-L//'`
-dnl fi
-
-dnl ;;
-dnl off)
-dnl dnl no --with-libssh2 option given, just check default places
-dnl ;;
-dnl *)
-dnl dnl use the given --with-libssh2 spot
-dnl PREFIX_SSH2=$OPT_LIBSSH2
-dnl ;;
-dnl esac
-
-dnl dnl if given with a prefix, we set -L and -I based on that
-dnl if test -n "$PREFIX_SSH2"; then
-dnl LIB_SSH2="-lssh2"
-dnl LD_SSH2=-L${PREFIX_SSH2}/lib$libsuff
-dnl CPP_SSH2=-I${PREFIX_SSH2}/include
-dnl DIR_SSH2=${PREFIX_SSH2}/lib$libsuff
-dnl fi
-
-dnl LDFLAGS="$LDFLAGS $LD_SSH2"
-dnl CPPFLAGS="$CPPFLAGS $CPP_SSH2"
-dnl LIBS="$LIB_SSH2 $LIBS"
-
-dnl AC_CHECK_LIB(ssh2, libssh2_channel_open_ex)
-
-dnl AC_CHECK_HEADERS(libssh2.h,
-dnl curl_ssh_msg="enabled (libSSH2)"
-dnl LIBSSH2_ENABLED=1
-dnl AC_DEFINE(USE_LIBSSH2, 1, [if libSSH2 is in use])
-dnl AC_SUBST(USE_LIBSSH2, [1])
-dnl )
-
-dnl if test X"$OPT_LIBSSH2" != Xoff &&
-dnl test "$LIBSSH2_ENABLED" != "1"; then
-dnl AC_MSG_ERROR([libSSH2 libs and/or directories were not found where specified!])
-dnl fi
-
-dnl if test "$LIBSSH2_ENABLED" = "1"; then
-dnl if test -n "$DIR_SSH2"; then
-dnl dnl when the libssh2 shared libs were found in a path that the run-time
-dnl dnl linker doesn't search through, we need to add it to LD_LIBRARY_PATH
-dnl dnl to prevent further configure tests to fail due to this
-
-dnl if test "x$cross_compiling" != "xyes"; then
-dnl LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$DIR_SSH2"
-dnl export LD_LIBRARY_PATH
-dnl AC_MSG_NOTICE([Added $DIR_SSH2 to LD_LIBRARY_PATH])
-dnl fi
-dnl fi
-dnl else
-dnl dnl no libssh2, revert back to clean variables
-dnl LDFLAGS=$CLEANLDFLAGS
-dnl CPPFLAGS=$CLEANCPPFLAGS
-dnl LIBS=$CLEANLIBS
-dnl fi
-dnl elif test X"$OPT_LIBSSH" != Xno; then
-dnl dnl backup the pre-libssh variables
-dnl CLEANLDFLAGS="$LDFLAGS"
-dnl CLEANCPPFLAGS="$CPPFLAGS"
-dnl CLEANLIBS="$LIBS"
-
-dnl case "$OPT_LIBSSH" in
-dnl yes)
-dnl dnl --with-libssh (without path) used
-dnl CURL_CHECK_PKGCONFIG(libssh)
-
-dnl if test "$PKGCONFIG" != "no" ; then
-dnl LIB_SSH=`$PKGCONFIG --libs-only-l libssh`
-dnl LD_SSH=`$PKGCONFIG --libs-only-L libssh`
-dnl CPP_SSH=`$PKGCONFIG --cflags-only-I libssh`
-dnl version=`$PKGCONFIG --modversion libssh`
-dnl DIR_SSH=`echo $LD_SSH | $SED -e 's/-L//'`
-dnl fi
-
-dnl ;;
-dnl off)
-dnl dnl no --with-libssh option given, just check default places
-dnl ;;
-dnl *)
-dnl dnl use the given --with-libssh spot
-dnl PREFIX_SSH=$OPT_LIBSSH
-dnl ;;
-dnl esac
-
-dnl dnl if given with a prefix, we set -L and -I based on that
-dnl if test -n "$PREFIX_SSH"; then
-dnl LIB_SSH="-lssh"
-dnl LD_SSH=-L${PREFIX_SSH}/lib$libsuff
-dnl CPP_SSH=-I${PREFIX_SSH}/include
-dnl DIR_SSH=${PREFIX_SSH}/lib$libsuff
-dnl fi
-
-dnl LDFLAGS="$LDFLAGS $LD_SSH"
-dnl CPPFLAGS="$CPPFLAGS $CPP_SSH"
-dnl LIBS="$LIB_SSH $LIBS"
-
-dnl AC_CHECK_LIB(ssh, ssh_new)
-
-dnl AC_CHECK_HEADERS(libssh/libssh.h,
-dnl curl_ssh_msg="enabled (libSSH)"
-dnl LIBSSH_ENABLED=1
-dnl AC_DEFINE(USE_LIBSSH, 1, [if libSSH is in use])
-dnl AC_SUBST(USE_LIBSSH, [1])
-dnl )
-
-dnl if test X"$OPT_LIBSSH" != Xoff &&
-dnl test "$LIBSSH_ENABLED" != "1"; then
-dnl AC_MSG_ERROR([libSSH libs and/or directories were not found where specified!])
-dnl fi
-
-dnl if test "$LIBSSH_ENABLED" = "1"; then
-dnl if test -n "$DIR_SSH"; then
-dnl dnl when the libssh shared libs were found in a path that the run-time
-dnl dnl linker doesn't search through, we need to add it to LD_LIBRARY_PATH
-dnl dnl to prevent further configure tests to fail due to this
-
-dnl if test "x$cross_compiling" != "xyes"; then
-dnl LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$DIR_SSH"
-dnl export LD_LIBRARY_PATH
-dnl AC_MSG_NOTICE([Added $DIR_SSH to LD_LIBRARY_PATH])
-dnl fi
-dnl fi
-dnl else
-dnl dnl no libssh, revert back to clean variables
-dnl LDFLAGS=$CLEANLDFLAGS
-dnl CPPFLAGS=$CLEANCPPFLAGS
-dnl LIBS=$CLEANLIBS
-dnl fi
-dnl fi
dnl **********************************************************************
dnl Check for the presence of LIBRTMP libraries and headers
@@ -2528,9 +2089,9 @@ if test "$want_idn" = "yes"; then
AC_SUBST([IDN_ENABLED], [1])
curl_idn_msg="enabled (libidn2)"
if test -n "$IDN_DIR" -a "x$cross_compiling" != "xyes"; then
- LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$IDN_DIR"
- export LD_LIBRARY_PATH
- AC_MSG_NOTICE([Added $IDN_DIR to LD_LIBRARY_PATH])
+ CURL_LIBRARY_PATH="$CURL_LIBRARY_PATH:$IDN_DIR"
+ export CURL_LIBRARY_PATH
+ AC_MSG_NOTICE([Added $IDN_DIR to CURL_LIBRARY_PATH])
fi
else
AC_MSG_WARN([Cannot find libraries for IDN support: IDN disabled])
@@ -2803,14 +2364,34 @@ AC_CHECK_TYPE([bool],[
#endif
])
+# check for sa_family_t
+AC_CHECK_TYPE(sa_family_t,
+ AC_DEFINE(CURL_SA_FAMILY_T, sa_family_t, [IP address type in sockaddr]),
+ [
+ # The windows name?
+ AC_CHECK_TYPE(ADDRESS_FAMILY,
+ AC_DEFINE(CURL_SA_FAMILY_T, ADDRESS_FAMILY, [IP address type in sockaddr]),
+ AC_DEFINE(CURL_SA_FAMILY_T, unsigned short, [IP address type in sockaddr]),
+ [
+#ifdef HAVE_SYS_SOCKET_H
+#include <sys/socket.h>
+#endif
+ ])
+ ],
+[
+#ifdef HAVE_SYS_SOCKET_H
+#include <sys/socket.h>
+#endif
+])
+
AC_MSG_CHECKING([if time_t is unsigned])
-AC_RUN_IFELSE([
- AC_LANG_SOURCE([[
+CURL_RUN_IFELSE(
+ [
#include <time.h>
#include <limits.h>
time_t t = -1;
return (t > 0);
- ]])] ,[
+ ],[
AC_MSG_RESULT([yes])
AC_DEFINE(HAVE_TIME_T_UNSIGNED, 1, [Define this if time_t is unsigned])
],[