summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNils Gillmann <ng0@n0.is>2018-09-11 10:16:59 +0000
committerNils Gillmann <ng0@n0.is>2018-09-11 10:16:59 +0000
commit8046e59880e096c1fe5e6a4b70ad57b7cd2d1354 (patch)
treec65cf5624bf702079df31be394de83da98b5b845 /configure.ac
parent87430bf69f13500b1feb363ffc099cede490b6e2 (diff)
parent432eb5f5c254ee8383b2522ce597c9219877923e (diff)
downloadgnurl-8046e59880e096c1fe5e6a4b70ad57b7cd2d1354.tar.gz
gnurl-8046e59880e096c1fe5e6a4b70ad57b7cd2d1354.tar.bz2
gnurl-8046e59880e096c1fe5e6a4b70ad57b7cd2d1354.zip
Merge tag 'curl-7_61_1'
curl 7.61.1 Signed-off-by: Nils Gillmann <ng0@n0.is>
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b21dd584f..113db4a43 100755
--- a/configure.ac
+++ b/configure.ac
@@ -61,6 +61,13 @@ AC_SUBST(CONFIGURE_OPTIONS)
CURL_CFLAG_EXTRAS=""
if test X"$want_werror" = Xyes; then
CURL_CFLAG_EXTRAS="-Werror"
+ if test "$compiler_id" = "GNU_C"; then
+ dnl enable -pedantic-errors for GCC 5 and later,
+ dnl as before that it was the same as -Werror=pedantic
+ if test "$compiler_num" -ge "500"; then
+ CURL_CFLAG_EXTRAS="$CURL_CFLAG_EXTRAS -pedantic-errors"
+ fi
+ fi
fi
AC_SUBST(CURL_CFLAG_EXTRAS)
@@ -1473,7 +1480,6 @@ dnl Default to compiler & linker defaults for SSL files & libraries.
OPT_SSL=off
dnl Default to no CA bundle
ca="no"
-
dnl **********************************************************************
dnl Check for the random seed preferences
dnl **********************************************************************