summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFabrice Fontaine <fontaine.fabrice@gmail.com>2018-05-21 12:07:00 +0200
committerDaniel Stenberg <daniel@haxx.se>2018-05-28 20:31:20 +0200
commit536e9f828997c39d67fcf09cb3b2c19d4cf216cc (patch)
tree7345923532524f8b9594ef5e69408008b625f84b /configure.ac
parenteb678badcb6783356a5160d91dc637701c919395 (diff)
downloadgnurl-536e9f828997c39d67fcf09cb3b2c19d4cf216cc.tar.gz
gnurl-536e9f828997c39d67fcf09cb3b2c19d4cf216cc.tar.bz2
gnurl-536e9f828997c39d67fcf09cb3b2c19d4cf216cc.zip
configure: fix ssh2 linking when built with a static mbedtls
The ssh2 pkg-config file could contain the following lines when build with a static version of mbedtls: Libs: -L${libdir} -lssh2 /xxx/libmbedcrypto.a Libs.private: /xxx/libmbedcrypto.a This static mbedtls library must be used to correctly detect ssh2 support and this library must be copied in libcurl.pc otherwise compilation of any application (such as upmpdcli) with libcurl will fail when trying to found mbedtls functions included in libssh2. So, replace pkg-config --libs-only-l by pkg-config --libs. Fixes: - http://autobuild.buildroot.net/results/43e24b22a77f616d6198c10435dcc23cc3b9088a Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Closes #2613
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c552c46ab..69a185044 100755
--- a/configure.ac
+++ b/configure.ac
@@ -2768,7 +2768,7 @@ if test X"$OPT_LIBSSH2" != Xno; then
CURL_CHECK_PKGCONFIG(libssh2)
if test "$PKGCONFIG" != "no" ; then
- LIB_SSH2=`$PKGCONFIG --libs-only-l libssh2`
+ LIB_SSH2=`$PKGCONFIG --libs libssh2`
LD_SSH2=`$PKGCONFIG --libs-only-L libssh2`
CPP_SSH2=`$PKGCONFIG --cflags-only-I libssh2`
version=`$PKGCONFIG --modversion libssh2`