summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNils Gillmann <gillmann@gnunet.org>2018-03-30 14:47:12 +0000
committerNils Gillmann <gillmann@gnunet.org>2018-03-30 14:47:12 +0000
commit4bdd2f26cf0ae539253feff8207e97ed4ce1d7ff (patch)
treeb8de037ad9c786b1799e33b5f38f8499ea35741b /configure.ac
parentb7ee0651926ee8706f066232f3c5d3b8a9c554fe (diff)
parent4d6bd91ab33328c6d27eddc32e064defc02dc4fd (diff)
downloadgnurl-4bdd2f26cf0ae539253feff8207e97ed4ce1d7ff.tar.gz
gnurl-4bdd2f26cf0ae539253feff8207e97ed4ce1d7ff.tar.bz2
gnurl-4bdd2f26cf0ae539253feff8207e97ed4ce1d7ff.zip
Merge tag 'curl-7_59_0' of https://github.com/curl/curl
curl 7.59.0 Initial merge of upstream tag.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac19
1 files changed, 18 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 34777f229..f946bb5b6 100755
--- a/configure.ac
+++ b/configure.ac
@@ -5,7 +5,7 @@
# | (__| |_| | _ <| |___
# \___|\___/|_| \_\_____|
#
-# Copyright (C) 1998 - 2017, Daniel Stenberg, <daniel@haxx.se>, et al.
+# Copyright (C) 1998 - 2018, Daniel Stenberg, <daniel@haxx.se>, et al.
#
# This software is licensed as described in the file COPYING, which
# you should have received as part of this distribution. The terms
@@ -2803,6 +2803,23 @@ AC_CHECK_TYPE([bool],[
#endif
])
+AC_MSG_CHECKING([if time_t is unsigned])
+AC_RUN_IFELSE([
+ AC_LANG_SOURCE([[
+ #include <time.h>
+ #include <limits.h>
+ time_t t = -1;
+ return (t > 0);
+ ]])] ,[
+ AC_MSG_RESULT([yes])
+ AC_DEFINE(HAVE_TIME_T_UNSIGNED, 1, [Define this if time_t is unsigned])
+],[
+ AC_MSG_RESULT([no])
+],[
+ dnl cross-compiling, most systems are unsigned
+ AC_MSG_RESULT([no])
+])
+
CURL_CONFIGURE_CURL_SOCKLEN_T
CURL_CONFIGURE_PULL_SYS_POLL