summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2019-01-25 10:14:25 +0100
committerDaniel Stenberg <daniel@haxx.se>2019-01-26 00:29:50 +0100
commit179311ec37ffed5b88f446f4348993a51a168abd (patch)
tree5901fd48c71f975a1d3ff41aa330968305f0a353 /configure.ac
parent3cbf731d9ec7146f9f1a6ac0fbd9af7fe358f5bb (diff)
downloadgnurl-179311ec37ffed5b88f446f4348993a51a168abd.tar.gz
gnurl-179311ec37ffed5b88f446f4348993a51a168abd.tar.bz2
gnurl-179311ec37ffed5b88f446f4348993a51a168abd.zip
configure: rewrite --enable-code-coverage
The previously used ax_code_coverage.m4 is not license compatible and must not be used. Reported-by: William A. Rowe Jr Fixes #3497 Closes #3499
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac10
1 files changed, 4 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 817a24a8e..c099ab94e 100755
--- a/configure.ac
+++ b/configure.ac
@@ -31,7 +31,7 @@ XC_OVR_ZZ60
CURL_OVERRIDE_AUTOCONF
dnl configure script copyright
-AC_COPYRIGHT([Copyright (c) 1998 - 2017 Daniel Stenberg, <daniel@haxx.se>
+AC_COPYRIGHT([Copyright (c) 1998 - 2019 Daniel Stenberg, <daniel@haxx.se>
This configure script may be copied, distributed and modified under the
terms of the curl license; see COPYING for more details])
@@ -131,11 +131,8 @@ dnl figure out the libcurl version
CURLVERSION=`$SED -ne 's/^#define LIBCURL_VERSION "\(.*\)".*/\1/p' ${srcdir}/include/curl/curlver.h`
XC_CHECK_PROG_CC
-dnl Check if gcc is being used before adding AX_CODE_COVERAGE
-AS_IF([ test "$GCC" = "yes" ], [AX_CODE_COVERAGE],
- # not using GCC so pass a test below - CODE_COVERAGE_ENABLED_TRUE is not zero length
- CODE_COVERAGE_ENABLED_TRUE='#'
-)
+dnl for --enable-code-coverage
+CURL_COVERAGE
XC_AUTOMAKE
AC_MSG_CHECKING([curl version])
@@ -4314,6 +4311,7 @@ AC_MSG_NOTICE([Configured to build curl/libcurl:
Built-in manual: ${curl_manual_msg}
--libcurl option: ${curl_libcurl_msg}
Verbose errors: ${curl_verbose_msg}
+ Code coverage: ${curl_coverage_msg}
SSPI support: ${curl_sspi_msg}
ca cert bundle: ${ca}${ca_warning}
ca cert path: ${capath}${capath_warning}