aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYang Tse <yangsita@gmail.com>2007-10-10 13:00:11 +0000
committerYang Tse <yangsita@gmail.com>2007-10-10 13:00:11 +0000
commitd09bac137a88ff80d2af0d08646b4551b2b5459b (patch)
tree936bba1909214fa07256f922b0ad973f017f43e3 /configure.ac
parent43e8f00861fa148d63ce349db8455a1739eeef14 (diff)
downloadgnurl-d09bac137a88ff80d2af0d08646b4551b2b5459b.tar.gz
gnurl-d09bac137a88ff80d2af0d08646b4551b2b5459b.tar.bz2
gnurl-d09bac137a88ff80d2af0d08646b4551b2b5459b.zip
improve checking for ldap.h and ldap_ssl.h header files
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 18 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 68d744220..78b26b493 100644
--- a/configure.ac
+++ b/configure.ac
@@ -544,7 +544,24 @@ AC_HELP_STRING([--with-lber-lib=libname],[Specify name of lber lib file]),
if test x$CURL_DISABLE_LDAP != x1 ; then
- AC_CHECK_HEADERS(ldap.h)
+ AC_CHECK_HEADERS(lber.h)
+
+ AC_CHECK_HEADERS(ldap.h,
+ [],[],[
+#if HAVE_LBER_H
+#include <lber.h>
+#endif
+])
+
+ AC_CHECK_HEADERS(ldap_ssl.h,
+ [],[],[
+#if HAVE_LBER_H
+#include <lber.h>
+#endif
+#if HAVE_LDAP_H
+#include <ldap.h>
+#endif
+])
if test -z "$LDAPLIBNAME" ; then
case $host in
@@ -572,8 +589,6 @@ fi
if test x$CURL_DISABLE_LDAP != x1 ; then
- AC_CHECK_HEADERS(lber.h)
-
if test "$LBERLIBNAME" ; then
dnl If name is "no" then don't define this library at all
dnl (it's only needed if libldap.so's dependencies are broken).
@@ -1768,7 +1783,6 @@ AC_CHECK_HEADERS(
assert.h \
unistd.h \
stdlib.h \
- ldap_ssl.h \
limits.h \
arpa/inet.h \
net/if.h \