aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2007-11-17 10:22:44 +0000
committerDaniel Stenberg <daniel@haxx.se>2007-11-17 10:22:44 +0000
commitbff962398d0f572b4ea689053e020080565944d5 (patch)
tree3b799b6dc60b90d59f58b4875b0cc622a9fc97fa /configure.ac
parent2b15823dab89d504eee57bf91f3757a90ab3497b (diff)
downloadgnurl-bff962398d0f572b4ea689053e020080565944d5.tar.gz
gnurl-bff962398d0f572b4ea689053e020080565944d5.tar.bz2
gnurl-bff962398d0f572b4ea689053e020080565944d5.zip
Andres Garcia made the examples build fine on Windows (mingw + msys) when
the lib was built staticly.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2be648541..70566cfbb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -174,6 +174,7 @@ case $host in
esac
AC_MSG_RESULT($mimpure)
AM_CONDITIONAL(MIMPURE, test x$mimpure = xyes)
+AM_CONDITIONAL(STATICLIB, false)
AC_MSG_CHECKING([if we need BUILDING_LIBCURL])
case $host in
@@ -185,6 +186,7 @@ case $host in
then
AC_DEFINE(CURL_STATICLIB, 1, [when not building a shared library])
AC_MSG_RESULT(yes)
+ AM_CONDITIONAL(STATICLIB, true)
else
AC_MSG_RESULT(no)
fi