aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYang Tse <yangsita@gmail.com>2007-03-07 17:59:03 +0000
committerYang Tse <yangsita@gmail.com>2007-03-07 17:59:03 +0000
commit74befdfbe0be43e02d72bbfd5021a1f61bc2684d (patch)
treecd236fa05b9be51d759bfa3006dd290a799423e0 /configure.ac
parentd31feb8ff9b905ddf7a73a966676ea4f9c197b02 (diff)
downloadgnurl-74befdfbe0be43e02d72bbfd5021a1f61bc2684d.tar.gz
gnurl-74befdfbe0be43e02d72bbfd5021a1f61bc2684d.tar.bz2
gnurl-74befdfbe0be43e02d72bbfd5021a1f61bc2684d.zip
force libtool to build static libraries with PIC on AMD64
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d54dd2fc5..5bcbce4fb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -127,6 +127,18 @@ m4_defun([AC_LIBTOOL_CXX],[])
m4_ifdef([AC_LIBTOOL_F77], [m4_undefine([AC_LIBTOOL_F77])])
m4_defun([AC_LIBTOOL_F77],[])
+dnl force libtool to build static libraries with PIC on AMD64
+AC_MSG_CHECKING([if target is AMD64 (to build static libraries with PIC)])
+case $host in
+ x86_64*linux* | *-*-cygwin)
+ AC_MSG_RESULT([yes])
+ with_pic=yes
+ ;;
+ *)
+ AC_MSG_RESULT([no])
+ ;;
+esac
+
dnl libtool setup
AC_PROG_LIBTOOL