aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2007-10-29 22:13:00 +0000
committerDaniel Stenberg <daniel@haxx.se>2007-10-29 22:13:00 +0000
commit57d2fb41d093a62f0e1ddfdfb94f136a0f4ab3a4 (patch)
tree545c725c10a9a6577397d109573feb95e1badfc0 /configure.ac
parent0f77fe55b6efbf090b30a3612b314cd2f8e27b3a (diff)
downloadgnurl-57d2fb41d093a62f0e1ddfdfb94f136a0f4ab3a4.tar.gz
gnurl-57d2fb41d093a62f0e1ddfdfb94f136a0f4ab3a4.tar.bz2
gnurl-57d2fb41d093a62f0e1ddfdfb94f136a0f4ab3a4.zip
Based on one of those bug reports that are intercepted by a distro's bug
tracker (https://bugzilla.redhat.com/show_bug.cgi?id=316191), I now made curl-config --features and --protocols show the correct output when built with NSS.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a0c4fae67..798ba6afc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1566,13 +1566,17 @@ fi dnl OPENSSL != 1 -a GNUTLS_ENABLED != 1
if test "x$OPENSSL_ENABLED$GNUTLS_ENABLED$NSS_ENABLED" = "x"; then
AC_MSG_WARN([SSL disabled, you will not be able to use HTTPS, FTPS, NTLM and more.])
AC_MSG_WARN([Use --with-ssl, --with-gnutls or --with-nss to address this.])
+else
+ # SSL is enabled, genericly
+ AC_SUBST(SSL_ENABLED)
+ SSL_ENABLED="1"
fi
dnl **********************************************************************
dnl Check for the CA bundle
dnl **********************************************************************
-if test X"$USE_NSS$USE_GNUTLS$OPENSSL_ENABLED" != "X"; then
+if test X"$SSL_ENABLED" != "X"; then
AC_MSG_CHECKING([CA cert bundle install path])