aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYang Tse <yangsita@gmail.com>2007-10-09 23:44:14 +0000
committerYang Tse <yangsita@gmail.com>2007-10-09 23:44:14 +0000
commit3337be81c8e1c28cb99885793edd4626163c2f08 (patch)
treeb801b85ef7cc61e05da74f69ab9f6a54015186ba /configure.ac
parent0cc9122093d2fc8715170d88d5292789b0b6a8ba (diff)
downloadgnurl-3337be81c8e1c28cb99885793edd4626163c2f08.tar.gz
gnurl-3337be81c8e1c28cb99885793edd4626163c2f08.tar.bz2
gnurl-3337be81c8e1c28cb99885793edd4626163c2f08.zip
Add check for lber.h and ldap.h header files
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0a40e5595..68d744220 100644
--- a/configure.ac
+++ b/configure.ac
@@ -544,6 +544,8 @@ AC_HELP_STRING([--with-lber-lib=libname],[Specify name of lber lib file]),
if test x$CURL_DISABLE_LDAP != x1 ; then
+ AC_CHECK_HEADERS(ldap.h)
+
if test -z "$LDAPLIBNAME" ; then
case $host in
*-*-cygwin* | *-*-mingw* | *-*-pw32*)
@@ -570,6 +572,8 @@ fi
if test x$CURL_DISABLE_LDAP != x1 ; then
+ AC_CHECK_HEADERS(lber.h)
+
if test "$LBERLIBNAME" ; then
dnl If name is "no" then don't define this library at all
dnl (it's only needed if libldap.so's dependencies are broken).