summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2012-11-23 11:56:26 +0100
committerDaniel Stenberg <daniel@haxx.se>2012-11-23 11:56:26 +0100
commit14dc679ce0b9018ebe1bc7d0356b7869747ecd96 (patch)
treec19dab6af73c59a69b60a281fd41f0abd278c1d4 /Makefile.am
parentef6f0403556afecc0a595915e016e7889eef0eb8 (diff)
downloadgnurl-14dc679ce0b9018ebe1bc7d0356b7869747ecd96.tar.gz
gnurl-14dc679ce0b9018ebe1bc7d0356b7869747ecd96.tar.bz2
gnurl-14dc679ce0b9018ebe1bc7d0356b7869747ecd96.zip
test: offer "automake" output and check for perl better
runtests.pl -am now uses the "PASS/FAIL: [desc]" output for each executed test. You can run 'make test-am' in the root build directory to invoke that. The reason for this output style is to better allow generic test suite parsers to also grok our test output. The test Makefile now also tests that perl was indeed found and that the PERL variable points to an executable before it tries to run the main test perl script runtests.pl,
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 6ff1d51ea..484e4df20 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -81,6 +81,9 @@ test-full:
test-torture:
@(cd tests; $(MAKE) all torture-test)
+test-am:
+ @(cd tests; $(MAKE) all am-test)
+
endif
examples: