summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2015-01-08 19:38:57 +0100
committerng0 <ng0@infotropique.org>2017-08-20 18:40:22 +0000
commit83c97b19e714790ceebc107dd8e6d4b349409d1c (patch)
treef6f9ff2babb15ab1ad8e0ab84f43527f3c8356f7 /CMakeLists.txt
parent8839c05fba1f8415eec17eff8ac60cc3a50eb51e (diff)
downloadgnurl-83c97b19e714790ceebc107dd8e6d4b349409d1c.tar.gz
gnurl-83c97b19e714790ceebc107dd8e6d4b349409d1c.tar.bz2
gnurl-83c97b19e714790ceebc107dd8e6d4b349409d1c.zip
Patchset for gnURL microfork:gnurl-7.55.1gnurl-7_55_1
* Patches to rename libcurl to libgnurl by Christian * Updated for latest curl using git cherry-pick by Jeff, Florian, ng0 * Patches to fix the testsuite (deleted tests/data/test1139, renamed reference from libcurl.* to libgnurl.*) by ng0 * Added guix-gnurl.scm which can be used to build this with guix prior to installing it. (author: ng0) * Further adjustments by ng0 * 7.55.0: Manual addition of a7bbbb7c368c6096802007f61f19a02e9d75285b and f864bd8c880d5a916379aa4f26f1c45fe370b282 from upstream master. * 7.55.1: Renamed include/curl to include/gnurl, a partial fix of https://gnunet.org/bugs/view.php?id=5122 Signed-off-by: ng0 <ng0@infotropique.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index af7f4dc40..be3fb4b3c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -48,7 +48,7 @@ project( CURL C )
message(WARNING "the curl cmake build system is poorly maintained. Be aware")
-file (READ ${CURL_SOURCE_DIR}/include/curl/curlver.h CURL_VERSION_H_CONTENTS)
+file (READ ${CURL_SOURCE_DIR}/include/gnurl/curlver.h CURL_VERSION_H_CONTENTS)
string (REGEX MATCH "#define LIBCURL_VERSION \"[^\"]*"
CURL_VERSION ${CURL_VERSION_H_CONTENTS})
string (REGEX REPLACE "[^\"]+\"" "" CURL_VERSION ${CURL_VERSION})
@@ -69,7 +69,7 @@ message(STATUS "curl version=[${CURL_VERSION}]")
set(OPERATING_SYSTEM "${CMAKE_SYSTEM_NAME}")
set(OS "\"${CMAKE_SYSTEM_NAME}\"")
-include_directories(${PROJECT_BINARY_DIR}/include/curl)
+include_directories(${PROJECT_BINARY_DIR}/include/gnurl)
include_directories( ${CURL_SOURCE_DIR}/include )
option(CURL_WERROR "Turn compiler warnings into errors" OFF)
@@ -1315,7 +1315,7 @@ if(NOT CURL_CONFIG_HAS_BEEN_RUN_BEFORE)
endif()
# install headers
-install(DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}/include/curl"
+install(DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}/include/gnurl"
DESTINATION include
FILES_MATCHING PATTERN "*.h")