aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2014-01-01 22:32:55 +0100
committerDaniel Stenberg <daniel@haxx.se>2014-01-01 22:33:26 +0100
commit5f8f512719f7407659053fdc406698c12d0892d1 (patch)
tree70a431e3e1044273d5f980c48f2a1aef5a9e3abf /CMakeLists.txt
parent6bc9e46bf1fc4bd739c2aa644b27179c753bb3b0 (diff)
downloadgnurl-5f8f512719f7407659053fdc406698c12d0892d1.tar.gz
gnurl-5f8f512719f7407659053fdc406698c12d0892d1.tar.bz2
gnurl-5f8f512719f7407659053fdc406698c12d0892d1.zip
CMakeLists.txt: add warning about the cmake build's state
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 761d9a473..ec93546e4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -23,6 +23,8 @@ include(Utilities)
project( CURL C )
+message(WARNING "the curl cmake build system is poorly maintained. Be aware")
+
file (READ ${CURL_SOURCE_DIR}/include/curl/curlver.h CURL_VERSION_H_CONTENTS)
string (REGEX MATCH "LIBCURL_VERSION_MAJOR[ \t]+([0-9]+)"
LIBCURL_VERSION_MJ ${CURL_VERSION_H_CONTENTS})