aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Wu <peter@lekensteyn.nl>2014-11-06 01:32:43 +0100
committerDaniel Stenberg <daniel@haxx.se>2014-11-10 09:07:50 +0100
commit10286f45e7c0813f6122cd8fd957e96a9f921b16 (patch)
tree0bab74de7c8b128e996e6b1ede960c7487bead93 /CMakeLists.txt
parent7bdfdd09e4ed32eb1ec690087b29a2a4c3a066ca (diff)
downloadgnurl-10286f45e7c0813f6122cd8fd957e96a9f921b16.tar.gz
gnurl-10286f45e7c0813f6122cd8fd957e96a9f921b16.tar.bz2
gnurl-10286f45e7c0813f6122cd8fd957e96a9f921b16.zip
cmake: fix HAVE_GETHOSTNAME definition
Otherwise Curl_gethostname always fails. Windows has gethostname since Vista according to http://msdn.microsoft.com/en-us/library/ms738527%28VS.85%29.aspx, but accordings to byte_bucket's VC 2005 documentation, it is available even in Windows 95. (possibly after installing a Platform SDK, the Windows Server 2003 SP1 Platform SDK should be sufficient). Signed-off-by: Peter Wu <peter@lekensteyn.nl>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 45f46ec5e..a325d1c1c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -252,6 +252,8 @@ if(NOT NOT_NEED_LIBNSL)
check_library_exists_concat("nsl" gethostbyname HAVE_LIBNSL)
endif(NOT NOT_NEED_LIBNSL)
+check_function_exists(gethostname HAVE_GETHOSTNAME)
+
if(WIN32)
check_library_exists_concat("ws2_32" getch HAVE_LIBWS2_32)
check_library_exists_concat("winmm" getch HAVE_LIBWINMM)