aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJakub Zakrzewski <jzakrzewski@e2ebridge.com>2014-08-15 14:51:13 +0200
committerDaniel Stenberg <daniel@haxx.se>2014-08-25 12:44:24 +0200
commitfebcfab23da536c3e4cb8422a452f74638a1ee66 (patch)
treed5506368800beb060df6c1f99f3a14d78d6d5bae /CMakeLists.txt
parent1269df2e3ba559c5367cb826d0414b2198102514 (diff)
downloadgnurl-febcfab23da536c3e4cb8422a452f74638a1ee66.tar.gz
gnurl-febcfab23da536c3e4cb8422a452f74638a1ee66.tar.bz2
gnurl-febcfab23da536c3e4cb8422a452f74638a1ee66.zip
Cmake: Removed useless comments from CMakeLists.txt
They look like some relics after changes.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 0 insertions, 10 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 00b740aa9..28a9c620e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -236,9 +236,6 @@ if(WIN32)
endif()
-# IF(NOT CURL_SPECIAL_LIBZ)
-# CHECK_LIBRARY_EXISTS_CONCAT("z" inflateEnd HAVE_LIBZ)
-# ENDIF(NOT CURL_SPECIAL_LIBZ)
# Check for idn
check_library_exists_concat("idn" idna_to_ascii_lz HAVE_LIBIDN)
@@ -248,9 +245,6 @@ check_library_exists_concat("ldap" ldap_init HAVE_LIBLDAP)
check_library_exists_concat("lber" ber_init HAVE_LIBLBER)
option(CMAKE_USE_OPENLDAP "Use OpenLDAP code." OFF)
mark_as_advanced(CMAKE_USE_OPENLDAP)
-# if(NOT HAVE_LIBLDAP)
-# SET(CURL_DISABLE_LDAP ON)
-# endif(NOT HAVE_LIBLDAP)
# Check for symbol dlopen (same as HAVE_LIBDL)
check_library_exists("${CURL_LIBS}" dlopen "" HAVE_DLOPEN)
@@ -848,15 +842,11 @@ endif(MSVC)
function(SETUP_CURL_DEPENDENCIES TARGET_NAME)
if(CURL_ZLIB AND ZLIB_FOUND)
include_directories(${ZLIB_INCLUDE_DIR})
- #ADD_DEFINITIONS( -DHAVE_ZLIB_H -DHAVE_ZLIB -DHAVE_LIBZ )
endif()
if(CMAKE_USE_OPENSSL AND OPENSSL_FOUND)
include_directories(${OPENSSL_INCLUDE_DIR})
endif()
- if(CMAKE_USE_OPENSSL AND CURL_CONFIG_HAS_BEEN_RUN_BEFORE)
- #ADD_DEFINITIONS( -DUSE_SSLEAY )
- endif()
if(CMAKE_USE_LIBSSH2 AND LIBSSH2_FOUND)
include_directories(${LIBSSH2_INCLUDE_DIR})