summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authormaxed <max.savenkov@gmail.com>2018-03-31 13:17:45 +0300
committerSergei Nikulov <snikulov@users.noreply.github.com>2018-05-28 08:05:16 +0300
commit7e93637acd9f5741ac4c09bbca353ac8da42bb17 (patch)
treee4be69e81d54de57c20c9612280e6001e38b618f /CMakeLists.txt
parentaa18b573c82ae73f49e59e7806b20cd7b4057d62 (diff)
downloadgnurl-7e93637acd9f5741ac4c09bbca353ac8da42bb17.tar.gz
gnurl-7e93637acd9f5741ac4c09bbca353ac8da42bb17.tar.bz2
gnurl-7e93637acd9f5741ac4c09bbca353ac8da42bb17.zip
Fix the test for fsetxattr and strerror_r tests in CMake to work without compiling
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b8c79f88a..685faf934 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -902,7 +902,7 @@ endif()
check_symbol_exists(fsetxattr "${CURL_INCLUDES}" HAVE_FSETXATTR)
if(HAVE_FSETXATTR)
foreach(CURL_TEST HAVE_FSETXATTR_5 HAVE_FSETXATTR_6)
- curl_internal_test_run(${CURL_TEST})
+ curl_internal_test(${CURL_TEST})
endforeach(CURL_TEST)
endif(HAVE_FSETXATTR)
@@ -982,7 +982,7 @@ foreach(CURL_TEST
HAVE_GLIBC_STRERROR_R
HAVE_POSIX_STRERROR_R
)
- curl_internal_test_run(${CURL_TEST})
+ curl_internal_test(${CURL_TEST})
endforeach(CURL_TEST)
# Check for reentrant