summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichaƂ Janiszewski <janisozaur@users.noreply.github.com>2018-03-27 15:22:37 +0200
committerSergei Nikulov <snikulov@users.noreply.github.com>2018-03-27 16:22:37 +0300
commitbea18c7f39d2d470c4965444519271e8ff380fb3 (patch)
tree9b9359c9e230a274f37c828b8ba79842c6fc5f38 /CMakeLists.txt
parent2bd8e684a4ca6614b49c10316146ede92d12bebf (diff)
downloadgnurl-bea18c7f39d2d470c4965444519271e8ff380fb3.tar.gz
gnurl-bea18c7f39d2d470c4965444519271e8ff380fb3.tar.bz2
gnurl-bea18c7f39d2d470c4965444519271e8ff380fb3.zip
cmake: Add advapi32 as explicit link library for win32
ARM targets need advapi32 explicitly. Closes #2363
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f44968b94..bf25b1f79 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -285,6 +285,7 @@ check_function_exists(gethostname HAVE_GETHOSTNAME)
if(WIN32)
check_library_exists_concat("ws2_32" getch HAVE_LIBWS2_32)
check_library_exists_concat("winmm" getch HAVE_LIBWINMM)
+ list(APPEND CURL_LIBS "advapi32")
endif()
# check SSL libraries