summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAkhil Kedia <akhil.kedia@samsung.com>2017-05-22 17:34:45 +0900
committerDaniel Stenberg <daniel@haxx.se>2017-05-23 10:07:08 +0200
commitb4d6b994454890269e79b439ac5d1492a626e9a6 (patch)
tree7524a93d888c718d14294e36653d4ddf1f864a29 /CMakeLists.txt
parenta1b3a95c96adb9624358c26976c5d22adeaab6ed (diff)
downloadgnurl-b4d6b994454890269e79b439ac5d1492a626e9a6.tar.gz
gnurl-b4d6b994454890269e79b439ac5d1492a626e9a6.tar.bz2
gnurl-b4d6b994454890269e79b439ac5d1492a626e9a6.zip
cmake: fix build on Ubuntu 14.04
Fixed a syntax error with setting cache variables (The type and docstring were missing), resulting in build errors. Quoted the CURL_CA_PATH and CURL_CA_BUNDLE otherwise the path was written without quotes in C code, resulting in build errors. Closes #1503 Signed-off-by: Akhil <akhil.kedia@samsung.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 078512056..99bfc7695 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -674,7 +674,7 @@ elseif(CURL_CA_PATH_AUTODETECT OR CURL_CA_BUNDLE_AUTODETECT)
if(EXISTS "${SEARCH_CA_BUNDLE_PATH}")
message(STATUS "Found CA bundle: ${SEARCH_CA_BUNDLE_PATH}")
set(CURL_CA_BUNDLE "${SEARCH_CA_BUNDLE_PATH}")
- set(CURL_CA_BUNDLE_SET TRUE CACHE)
+ set(CURL_CA_BUNDLE_SET TRUE CACHE BOOL "Path to the CA bundle has been set")
break()
endif()
endforeach()
@@ -683,7 +683,7 @@ elseif(CURL_CA_PATH_AUTODETECT OR CURL_CA_BUNDLE_AUTODETECT)
if(CURL_CA_PATH_AUTODETECT AND (NOT CURL_CA_PATH_SET))
if(EXISTS "/etc/ssl/certs")
set(CURL_CA_PATH "/etc/ssl/certs")
- set(CURL_CA_PATH_SET TRUE CACHE)
+ set(CURL_CA_PATH_SET TRUE CACHE BOOL "Path to the CA bundle has been set")
endif()
endif()
endif()