summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2017-07-05 10:21:58 +0200
committerDaniel Stenberg <daniel@haxx.se>2017-07-05 13:28:28 +0200
commit9ee6cb1b77c7a9a17c5ce380cec72066e13b1ebf (patch)
tree1e62ffda0fd6a04f83a701b9eafda4e8edf71d75 /CMakeLists.txt
parent7e21e5fd0c709d79ab27c65fd0afff4cf34e0da9 (diff)
downloadgnurl-9ee6cb1b77c7a9a17c5ce380cec72066e13b1ebf.tar.gz
gnurl-9ee6cb1b77c7a9a17c5ce380cec72066e13b1ebf.tar.bz2
gnurl-9ee6cb1b77c7a9a17c5ce380cec72066e13b1ebf.zip
cmake: if inet_pton is used, bump _WIN32_WINNT
... and make sure inet_pton is always checked for when *not* using Windows, which is a regression from 4fc6ebe18. Idea-by: Sergei Nikulov
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt18
1 files changed, 11 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 727ca8153..5d8b9f10f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -932,8 +932,17 @@ check_symbol_exists(ioctl "${CURL_INCLUDES}" HAVE_IOCTL)
check_symbol_exists(setsockopt "${CURL_INCLUDES}" HAVE_SETSOCKOPT)
# symbol exists in win32, but function does not.
-if(ENABLE_INET_PTON)
- check_function_exists(inet_pton HAVE_INET_PTON)
+if(WIN32)
+ if(ENABLE_INET_PTON)
+ check_function_exists(inet_pton HAVE_INET_PTON)
+ # _WIN32_WINNT_VISTA (0x0600)
+ add_definitions(-D_WIN32_WINNT=0x0600)
+ else()
+ # _WIN32_WINNT_WINXP (0x0501)
+ add_definitions(-D_WIN32_WINNT=0x0501)
+ endif()
+else()
+ check_function_exists(inet_pton HAVE_INET_PTON)
endif()
check_symbol_exists(fsetxattr "${CURL_INCLUDES}" HAVE_FSETXATTR)
@@ -1136,11 +1145,6 @@ include(CMake/OtherTests.cmake)
add_definitions(-DHAVE_CONFIG_H)
-# For windows, do not allow the compiler to use default target (Vista).
-if(WIN32)
- add_definitions(-D_WIN32_WINNT=0x0501)
-endif(WIN32)
-
# For windows, all compilers used by cmake should support large files
if(WIN32)
set(USE_WIN32_LARGE_FILES ON)