summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2017-10-05 10:16:40 +0200
committerDaniel Stenberg <daniel@haxx.se>2017-10-09 11:29:53 +0200
commit62a721ea47e1e697faa7e3d87c8c9025808a8667 (patch)
tree31acc246f817519a1f8373a345bd9430ce12d3ab /CMakeLists.txt
parentc95c92da7584483368c8761c8cca276b5401530c (diff)
downloadgnurl-62a721ea47e1e697faa7e3d87c8c9025808a8667.tar.gz
gnurl-62a721ea47e1e697faa7e3d87c8c9025808a8667.tar.bz2
gnurl-62a721ea47e1e697faa7e3d87c8c9025808a8667.zip
openssl: enable PKCS12 support for !BoringSSL
Enable PKCS12 for all non-boringssl builds without relying on configure or cmake checks. Bug: https://curl.haxx.se/mail/lib-2017-10/0007.html Reported-by: Christian Schmitz Closes #1948
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 261baba5c..3bfb5febd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -366,7 +366,6 @@ if(CMAKE_USE_OPENSSL)
check_include_file("openssl/engine.h" HAVE_OPENSSL_ENGINE_H)
check_include_file("openssl/err.h" HAVE_OPENSSL_ERR_H)
check_include_file("openssl/pem.h" HAVE_OPENSSL_PEM_H)
- check_include_file("openssl/pkcs12.h" HAVE_OPENSSL_PKCS12_H)
check_include_file("openssl/rsa.h" HAVE_OPENSSL_RSA_H)
check_include_file("openssl/ssl.h" HAVE_OPENSSL_SSL_H)
check_include_file("openssl/x509.h" HAVE_OPENSSL_X509_H)