summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSergei Nikulov <sergey.nikulov@gmail.com>2018-05-24 00:37:53 +0300
committerSergei Nikulov <snikulov@users.noreply.github.com>2018-05-24 17:25:41 +0300
commit2c0225e0423eea2c76e68f50c766b112d1303d92 (patch)
tree71ccd5f3256ef054efece25da0ba6e6b48991dda /CMakeLists.txt
parentd353af001420574210605ba132dfd31a0e3876a5 (diff)
downloadgnurl-2c0225e0423eea2c76e68f50c766b112d1303d92.tar.gz
gnurl-2c0225e0423eea2c76e68f50c766b112d1303d92.tar.bz2
gnurl-2c0225e0423eea2c76e68f50c766b112d1303d92.zip
cmake: set -d postfix for debug builds if not specified
using -DCMAKE_DEBUG_POSTFIX explicitly fixes #2121, obsoletes #2384
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bf25b1f79..b8c79f88a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -118,7 +118,9 @@ if (ENABLE_CURLDEBUG)
endif()
# For debug libs and exes, add "-d" postfix
-set(CMAKE_DEBUG_POSTFIX "-d" CACHE STRING "Set debug library postfix")
+if(NOT DEFINED CMAKE_DEBUG_POSTFIX)
+ set(CMAKE_DEBUG_POSTFIX "-d")
+endif()
# initialize CURL_LIBS
set(CURL_LIBS "")