aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSergei Nikulov <sergey.nikulov@gmail.com>2016-06-16 13:53:50 +0300
committerDaniel Stenberg <daniel@haxx.se>2016-06-21 23:04:04 +0200
commit12e21fab26bd83dfa75f009a24380d144ea51857 (patch)
treed1a745c42a4ac1887de5a56928d3bc6f9544dda7 /CMakeLists.txt
parent0bdec5e01d9914d97bb9ed1301b1590162fe2945 (diff)
downloadgnurl-12e21fab26bd83dfa75f009a24380d144ea51857.tar.gz
gnurl-12e21fab26bd83dfa75f009a24380d144ea51857.tar.bz2
gnurl-12e21fab26bd83dfa75f009a24380d144ea51857.zip
cmake: now using BUILD_TESTING=ON/OFF
CMake build now using BUILD_TESTING=ON/OFF (default is OFF) to build tests and enabling CTest integration. Options BUILD_CURL_TESTS and BUILD_DASHBOARD_REPORTS was removed. Closes #882 Reviewed-by: Brad King
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 3 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 630e4a553..58b145170 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -72,7 +72,6 @@ include_directories(${PROJECT_BINARY_DIR}/include/curl)
include_directories( ${CURL_SOURCE_DIR}/include )
option(BUILD_CURL_EXE "Set to ON to build cURL executable." ON)
-option(BUILD_CURL_TESTS "Set to ON to build cURL tests." ON)
option(CURL_STATICLIB "Set to ON to build libcurl with static linking." OFF)
option(ENABLE_ARES "Set to ON to enable c-ares support" OFF)
option(ENABLE_THREADED_RESOLVER "Set to ON to enable POSIX threaded DNS lookup" OFF)
@@ -108,12 +107,6 @@ if(ENABLE_ARES)
set(CURL_LIBS ${CURL_LIBS} ${CARES_LIBRARY})
endif()
-option(BUILD_DASHBOARD_REPORTS "Set to ON to activate reporting of cURL builds here http://www.cdash.org/CDashPublic/index.php?project=CURL" OFF)
-if(BUILD_DASHBOARD_REPORTS)
- #INCLUDE(Dart)
- include(CTest)
-endif(BUILD_DASHBOARD_REPORTS)
-
if(MSVC)
option(BUILD_RELEASE_DEBUG_DIRS "Set OFF to build each configuration to a separate directory" OFF)
mark_as_advanced(BUILD_RELEASE_DEBUG_DIRS)
@@ -1041,7 +1034,9 @@ add_subdirectory(lib)
if(BUILD_CURL_EXE)
add_subdirectory(src)
endif()
-if(BUILD_CURL_TESTS)
+
+include(CTest)
+if(BUILD_TESTING)
add_subdirectory(tests)
endif()