summaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am14
1 files changed, 10 insertions, 4 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index e57e1c5d2..2a5cdefef 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -1,6 +1,11 @@
# This Makefile.am is in the public domain
AM_CPPFLAGS = -I$(top_srcdir)/src/include $(LIBGCRYPT_CFLAGS) $(POSTGRESQL_CPPFLAGS)
+if USE_COVERAGE
+ AM_CFLAGS = --coverage -O0
+ XLIB = -lgcov
+endif
+
lib_LTLIBRARIES = \
libtalerutil.la
@@ -16,20 +21,21 @@ libtalerutil_la_LIBADD = \
-lgnunetutil \
$(LIBGCRYPT_LIBS) \
-ljansson \
- -lmicrohttpd
+ -lmicrohttpd $(XLIB)
libtalerutil_la_LDFLAGS = \
-version-info 0:0:0 \
-export-dynamic -no-undefined
-TESTS=\
+TESTS = \
test-json-validations
check_PROGRAMS=\
test-json-validations
-test_json_validations_SOURCES=test_json_validations.c
-test_json_validations_LDADD=\
+test_json_validations_SOURCES = \
+ test_json_validations.c
+test_json_validations_LDADD = \
-lgnunetutil \
-ljansson \
libtalerutil.la