summaryrefslogtreecommitdiff
path: root/src/exchangedb/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/exchangedb/Makefile.am')
-rw-r--r--src/exchangedb/Makefile.am26
1 files changed, 20 insertions, 6 deletions
diff --git a/src/exchangedb/Makefile.am b/src/exchangedb/Makefile.am
index 6145740c4..07c0bf68a 100644
--- a/src/exchangedb/Makefile.am
+++ b/src/exchangedb/Makefile.am
@@ -14,17 +14,25 @@ pkgcfg_DATA = \
sqldir = $(prefix)/share/taler/sql/exchange/
-sql_DATA = \
- benchmark-0000.sql \
- benchmark-0001.sql \
- exchange-0000.sql \
- exchange-0001-part.sql \
- shard-0001-part.sql \
+sqlinputs = \
common-0001.sql \
drop-common.sql \
+ exchange-0001-part.sql \
drop0001-exchange-part.sql \
+ shard-0001-part.sql \
drop0001-shard-part.sql
+sql_DATA = \
+ benchmark-0000.sql \
+ benchmark-0001.sql \
+ exchange-0000.sql \
+ exchange-0001.sql \
+ drop0001.sql \
+ shard-0000.sql \
+ shard-0001.sql \
+ shard-drop0001.sql
+
+
BUILT_SOURCES = \
shard-0000.sql \
shard-0001.sql \
@@ -40,22 +48,27 @@ CLEANFILES = \
shard-drop0001.sql
exchange-0001.sql: common-0001.sql exchange-0001-part.sql
+ chmod +w $@ || true
cat common-0001.sql exchange-0001-part.sql >$@
chmod -w $@
shard-0001.sql: common-0001.sql shard-0001-part.sql
+ chmod +w $@ || true
cat common-0001.sql shard-0001-part.sql >$@
chmod -w $@
shard-0000.sql: exchange-0000.sql
+ chmod +w $@ || true
cp exchange-0000.sql $@
chmod -w $@
drop0001.sql: drop-common.sql drop0001-exchange-part.sql
+ chmod +w $@ || true
cat drop-common.sql drop0001-exchange-part.sql >$@
chmod -w $@
shard-drop0001.sql: drop-common.sql drop0001-shard-part.sql
+ chmod +w $@ || true
cat drop-common.sql drop0001-shard-part.sql >$@
chmod -w $@
@@ -67,6 +80,7 @@ EXTRA_DIST = \
lrbt_callbacks.c \
bench-db-postgres.conf \
test-exchange-db-postgres.conf \
+ $(sqlinputs) \
$(sql_DATA)
plugindir = $(libdir)/taler