summaryrefslogtreecommitdiff
path: root/src/exchange/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/exchange/Makefile.am')
-rw-r--r--src/exchange/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/exchange/Makefile.am b/src/exchange/Makefile.am
index 41083502d..add8948b2 100644
--- a/src/exchange/Makefile.am
+++ b/src/exchange/Makefile.am
@@ -19,6 +19,7 @@ pkgcfg_DATA = \
bin_PROGRAMS = \
taler-exchange-aggregator \
taler-exchange-closer \
+ taler-exchange-drain \
taler-exchange-expire \
taler-exchange-httpd \
taler-exchange-router \
@@ -52,6 +53,19 @@ taler_exchange_closer_LDADD = \
-lgnunetutil \
$(XLIB)
+taler_exchange_drain_SOURCES = \
+ taler-exchange-drain.c
+taler_exchange_drain_LDADD = \
+ $(LIBGCRYPT_LIBS) \
+ $(top_builddir)/src/json/libtalerjson.la \
+ $(top_builddir)/src/util/libtalerutil.la \
+ $(top_builddir)/src/bank-lib/libtalerbank.la \
+ $(top_builddir)/src/exchangedb/libtalerexchangedb.la \
+ -ljansson \
+ -lgnunetcurl \
+ -lgnunetutil \
+ $(XLIB)
+
taler_exchange_expire_SOURCES = \
taler-exchange-expire.c
taler_exchange_expire_LDADD = \