summaryrefslogtreecommitdiff
path: root/src/exchange/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/exchange/Makefile.am')
-rw-r--r--src/exchange/Makefile.am23
1 files changed, 22 insertions, 1 deletions
diff --git a/src/exchange/Makefile.am b/src/exchange/Makefile.am
index e29a51bbb..18a7c1b54 100644
--- a/src/exchange/Makefile.am
+++ b/src/exchange/Makefile.am
@@ -59,4 +59,25 @@ check_SCRIPTS += \
test_taler_exchange_httpd_afl.sh
endif
-TESTS = $(check_SCRIPTS)
+test_taler_exchange_aggregator_postgres_SOURCES = \
+ test_taler_exchange_aggregator.c
+test_taler_exchange_aggregator_postgres_LDADD = \
+ $(LIBGCRYPT_LIBS) \
+ $(top_builddir)/src/exchangedb/libtalerexchangedb.la \
+ $(top_builddir)/src/util/libtalerutil.la \
+ -lmicrohttpd \
+ -lgnunetutil \
+ -lgnunetjson \
+ -ljansson \
+ -lpthread
+
+check_PROGRAMS = \
+ test_taler_exchange_aggregator-postgres
+
+TESTS = \
+ $(check_SCRIPTS) \
+ $(check_PROGRAMS)
+
+
+EXTRA_DIST = \
+ test-taler-exchange-aggregator-postgres.conf