summaryrefslogtreecommitdiff
path: root/src/benchmark/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/benchmark/Makefile.am')
-rw-r--r--src/benchmark/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/src/benchmark/Makefile.am b/src/benchmark/Makefile.am
new file mode 100644
index 000000000..4deb81723
--- /dev/null
+++ b/src/benchmark/Makefile.am
@@ -0,0 +1,22 @@
+# This Makefile.am is in the public domain
+AM_CPPFLAGS = -I$(top_srcdir)/src/include
+
+if USE_COVERAGE
+ AM_CFLAGS = --coverage -O0
+ XLIB = -lgcov
+endif
+
+bin_PROGRAMS = \
+ taler-exchange-benchmark
+
+taler_exchange_benchmark_SOURCES = \
+ taler-exchange-benchmark.c
+taler_exchange_benchmark_LDADD = \
+ $(LIBGCRYPT_LIBS) \
+ -ltalerexchange \
+ -ltalerjson \
+ -ltalerutil \
+ -lgnunetjson \
+ -lgnunetcurl \
+ -lgnunetutil \
+ -ljansson