summaryrefslogtreecommitdiff
path: root/src/json/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2019-06-26 20:43:08 +0200
committerChristian Grothoff <christian@grothoff.org>2019-06-26 20:43:08 +0200
commit9a5030b993d74732f8fba2879cfca03ec070ad9a (patch)
tree7e47603cacc59d6c339484acdffb9aa0726da7f9 /src/json/Makefile.am
parent35fe98a1657086af959e4512bb79b04e81ed3fc1 (diff)
downloadexchange-9a5030b993d74732f8fba2879cfca03ec070ad9a.tar.gz
exchange-9a5030b993d74732f8fba2879cfca03ec070ad9a.tar.bz2
exchange-9a5030b993d74732f8fba2879cfca03ec070ad9a.zip
add test for json_wire.c logic
Diffstat (limited to 'src/json/Makefile.am')
-rw-r--r--src/json/Makefile.am16
1 files changed, 14 insertions, 2 deletions
diff --git a/src/json/Makefile.am b/src/json/Makefile.am
index 22173d0a0..2ac5df44b 100644
--- a/src/json/Makefile.am
+++ b/src/json/Makefile.am
@@ -25,10 +25,12 @@ libtalerjson_la_LIBADD = \
$(XLIB)
TESTS = \
- test_json
+ test_json \
+ test_json_wire
check_PROGRAMS= \
- test_json
+ test_json \
+ test_json_wire
test_json_SOURCES = \
test_json.c
@@ -38,3 +40,13 @@ test_json_LDADD = \
$(top_builddir)/src/util/libtalerutil.la \
-lgnunetutil \
-ljansson
+
+
+test_json_wire_SOURCES = \
+ test_json_wire.c
+test_json_wire_LDADD = \
+ $(top_builddir)/src/json/libtalerjson.la \
+ -lgnunetjson \
+ $(top_builddir)/src/util/libtalerutil.la \
+ -lgnunetutil \
+ -ljansson