summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2016-03-02 21:07:27 +0100
committerChristian Grothoff <christian@grothoff.org>2016-03-02 21:07:27 +0100
commit17ff4f5e97b981f0b3eebd6e3923fe60dc75edd5 (patch)
tree585b6cbe92aec91b2e186206c1bfe746a0cd85e6 /src/Makefile.am
parent531272a92a5aa08559436138ff5106a6bff1b361 (diff)
parent201b2b3d1af2a4d44fe32c8b0312d935845cf129 (diff)
downloadexchange-17ff4f5e97b981f0b3eebd6e3923fe60dc75edd5.tar.gz
exchange-17ff4f5e97b981f0b3eebd6e3923fe60dc75edd5.tar.bz2
exchange-17ff4f5e97b981f0b3eebd6e3923fe60dc75edd5.zip
fixing #4230 in bank-lib
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am14
1 files changed, 11 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ac839d52a..37c902e65 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -3,16 +3,24 @@ AM_CPPFLAGS = -I$(top_srcdir)/src/include
if HAVE_POSTGRESQL
PQ_DIR = pq
endif
+if HAVE_LIBCURL
+ BANK_LIB = bank-lib
+else
+if HAVE_LIBGNURL
+ BANK_LIB = bank-lib
+endif
+endif
+
if WALLET_ONLY
SUBDIRS = include util
else
-SUBDIRS = include util $(PQ_DIR) bank-lib wire mintdb mint mint-tools
+SUBDIRS = include util $(PQ_DIR) $(BANK_LIB) wire exchangedb exchange exchange-tools
if HAVE_LIBCURL
- SUBDIRS += mint-lib
+ SUBDIRS += exchange-lib
else
if HAVE_LIBGNURL
- SUBDIRS += mint-lib
+ SUBDIRS += exchange-lib
endif
endif