summaryrefslogtreecommitdiff
path: root/doc/doxygen/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2015-03-28 15:42:07 +0100
committerChristian Grothoff <christian@grothoff.org>2015-03-28 15:42:07 +0100
commiteca4f1a8fe52d463b6b87d19c245e7aa02197476 (patch)
tree2340cf88788df283b8b4b9be99984939d9943805 /doc/doxygen/Makefile.am
parentc2fd4896a69a2404fc8b468da2cb6161db97bb3d (diff)
downloadexchange-eca4f1a8fe52d463b6b87d19c245e7aa02197476.tar.gz
exchange-eca4f1a8fe52d463b6b87d19c245e7aa02197476.tar.bz2
exchange-eca4f1a8fe52d463b6b87d19c245e7aa02197476.zip
-doxygen fixes
Diffstat (limited to 'doc/doxygen/Makefile.am')
-rw-r--r--doc/doxygen/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/doc/doxygen/Makefile.am b/doc/doxygen/Makefile.am
new file mode 100644
index 000000000..6b6f1ed72
--- /dev/null
+++ b/doc/doxygen/Makefile.am
@@ -0,0 +1,18 @@
+# This Makefile.am is in the public domain
+all:
+ @echo -e \
+"Generate documentation:\n" \
+"\tmake full - full documentation with dependency graphs (slow)\n" \
+"\tmake fast - fast mode without dependency graphs"
+
+full: taler-mint.doxy
+ doxygen $<
+
+fast: taler-mint.doxy
+ sed 's/\(HAVE_DOT.*=\).*/\1 NO/' $< | doxygen -
+
+clean:
+ rm -rf html
+
+
+EXTRA_DIST = taler-mint.doxy