summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2017-10-24 15:37:46 +0200
committerChristian Grothoff <christian@grothoff.org>2017-10-24 15:37:46 +0200
commitd107baa2c30980b85f6330f3f7c3287b4d58708b (patch)
treec1a88862b9c08a9fb51d199b27cbeadcb871a896 /configure.ac
parent288c7160d7ab892ed8e45e57f772bc0ebf180649 (diff)
downloadexchange-d107baa2c30980b85f6330f3f7c3287b4d58708b.tar.gz
exchange-d107baa2c30980b85f6330f3f7c3287b4d58708b.tar.bz2
exchange-d107baa2c30980b85f6330f3f7c3287b4d58708b.zip
fix #5108
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 454de712..1b904b59 100644
--- a/configure.ac
+++ b/configure.ac
@@ -472,6 +472,14 @@ AC_TYPE_UINTMAX_T
# Checks for library functions.
AC_CHECK_FUNCS([strdup])
+
+AC_ARG_ENABLE([[doc]],
+ [AS_HELP_STRING([[--disable-doc]], [do not build any documentation])], ,
+ [enable_doc=yes])
+test "x$enable_doc" = "xno" || enable_doc=yes
+AM_CONDITIONAL([ENABLE_DOC], [test "x$enable_doc" = "xyes"])
+
+
else
# logic if doc_only is set, make sure conditionals are still defined
@@ -482,6 +490,7 @@ AM_CONDITIONAL([HAVE_LIBCURL], [false])
AM_CONDITIONAL([HAVE_LIBGNURL], [false])
AM_CONDITIONAL([HAVE_DEVELOPER], [false])
AM_CONDITIONAL([USE_COVERAGE], [false])
+AM_CONDITIONAL([ENABLE_DOC], [true])
# end of 'doc_only'