summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcello Stanisci <stanisci.m@gmail.com>2018-09-05 14:10:01 +0200
committerMarcello Stanisci <stanisci.m@gmail.com>2018-09-05 14:10:01 +0200
commit8e28dfaebe656b6aa36d84c9d6c546a003f5450b (patch)
treecc21580d96853262fbfba24f22dd852ad91c9e79 /configure.ac
parent9316f63b7f869cd3a9124b3a846aeb2ba2022563 (diff)
downloadexchange-8e28dfaebe656b6aa36d84c9d6c546a003f5450b.tar.gz
exchange-8e28dfaebe656b6aa36d84c9d6c546a003f5450b.tar.bz2
exchange-8e28dfaebe656b6aa36d84c9d6c546a003f5450b.zip
minor polishing
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 3c7151ae..f1a6c1c3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -43,7 +43,7 @@ AC_ARG_ENABLE([only-doc],
[doc_only=${enableval}],
[doc_only=no])
AC_MSG_RESULT($doc_only)
-AM_CONDITIONAL([DOC_ONLY], [test "$doc_only" = "yes"])
+AM_CONDITIONAL([DOC_ONLY], [test "x$doc_only" = "xyes"])
if test "$doc_only" != yes
then
@@ -88,11 +88,14 @@ AC_MSG_RESULT($enable_expensive)
AM_CONDITIONAL([HAVE_EXPENSIVE_TESTS], [test "x$enable_expensive" = "xyes"])
+AC_MSG_CHECKING(whether to enable epoll)
AC_ARG_ENABLE([[epoll]],
[AS_HELP_STRING([[--enable-epoll[=ARG]]], [enable epoll support (yes, no, auto) [auto]])],
[enable_epoll=${enableval}],
[enable_epoll='auto']
)
+AC_MSG_RESULT($enable_epoll)
+AM_CONDITIONAL([MHD_HAVE_EPOLL], [test "x$enable_epoll" = "xyes"])
AS_IF([test "$enable_epoll" != "no"],
[AX_HAVE_EPOLL
@@ -103,7 +106,6 @@ AS_IF([test "$enable_epoll" != "no"],
AC_MSG_ERROR([[Support for epoll was explicitly requested but cannot be enabled on this platform.]]))
enable_epoll='no'])])
-AM_CONDITIONAL([MHD_HAVE_EPOLL], [[test "x$enable_epoll" = xyes]])
AS_IF([test "x$enable_epoll" = "xyes"],
AC_CACHE_CHECK([for epoll_create1()],